SG-2440\. Reset Button not resetting. How get factory default?



  • SG-2440. Reset Button not resetting. How get factory default?

    Just started working with a newly received SG-2440.  New to PFsense and while testing some settings I have locked myself out of the unit (WebGUI and console as well).

    I thought it would be a simple "push the reset and get the factory defaults back" but nothing seems to change when I press the reset button (I have tried holding it, multiple presses).

    Anyone know what the proper reset procedure is for returning to factory defaults?

    Thanks,

    Todd

    • SG2440, SG 2440.

  • Banned

    Connect a console and use the menu?


  • Netgate Administrator

    Yes, use the USB console to either roll back whatever change locked you out or reset to factory defaults.

    Steve



  • The reset button does reset to factory default, but is only active at power on.

    https://forum.pfsense.org/index.php?topic=92029.msg509872#msg509872



  • The button is connected to a GPIO pin that is tested at power on.  Steve in Customer Service told me that there was a problem with the button not working with pfSense 2.2.1 but that it should be fixed in 2.2.2.

    However, it doesn't work for me even with 2.2.2.  I tried several times.

    It isn't helped by the button being recessed and the power socket is about 1cm away from the button.  The power plug has to be connected while depressing the button with a screwdriver which requires some manual dexterity because they are so close.  It would be much easier if there was a power switch.

    The button not resetting was awkward because the console was not working after reloading the configuration, and SSH was turned off.  Reloading the configuration appears to remove the line in loader.conf that sets the serial port to 0x2f8.

    I had to resort to reinstalling from a USB key, modifying the configuration file to enable SSH, and reloading the configuration.  Then I could use SSH to add the correct serial port address to loader.conf.


Log in to reply