Why doesnt the basics work anymore ???



  • It should work, its so simple, but it doesn't.  :'(

    CASE1… ok this works...

    [pfsense box]

    • with most things on default…
      LAN: 192.168.1.1 /24 <- the network that needs internet to 8 port switch Asus1
      WAN: ip 192.168.0.2 /24 <- connects to buffalo below LAN1 port. There are also 2 PC-s at LAN2&LAN3
                gw 192.168.0.10

    [Buffalo Wifi Router]

    • wireless disabled for testing…
      LAN: 192.168.0.10 /24
      WAN: ip 214.35.203.214 /30 <- connects to ZyXEL below, Ethernet port
                gw 214.35.203.213

    [ZyXEL ADSL router/modem]

    • does not route, no NAT…
      LAN=WAN: 214.35.203.213
      DSL link works and is up.

    :)
    CASE2… this fails miserably... no idea why ?!? ??? !?!

    [pfsense box]
    LAN: 192.168.1.1 /24 <- same as above
    WAN: ip 214.35.203.214 /30 <- connects to ZyXEL
              gw 214.35.203.213

    [ZyXEL ADSL router/modem]
    LAN=WAN: 214.35.203.213
    DSL link works and is up.

    :-\

    I want to get rid of the buffalo between…
    something is wrong with the world i think... or is it pfsense ?
    Because at the moment Buffalo does a better job... tho it lacs all the other neat stuff....



  • Does your buffalo router have the MAC of the cable modem cloned?



  • Reset the modem. It probably has an th eold mac adress of the buffalo cached in it's arpcache. If that doesn'T help take the line out of service for some minutes (unpower the zyxel) to make sure the ISP gateway is dumping it's arp cache too.



  • Will try this and report back…
    Thanks for the note on the arpa cache...

    But i didn't quite understand about the "MAC clone". Usually i dont "spoof" MAC-s.



  • Did you use the clone mac feature? Don't do that unless you really need to. This might cause ARP problems if the device that originally has that mac is still online.



  • i see now… the MAC address option in pfsense... i clicked it when i nothing else worked, so i dont think thats the problem... and i didn't change the default one it gave me.... haven't have time to test pfsense again... soon i will.



  • ;) I took off every switch, modem and router, preconfigured pfsense, connected cables and restarted the devices in this order:
    modem -> router -> switches -> pfsensebox
    And it worked :)



  • That was probably some arp (argh!) problem then  ;)


Locked