PFSense USB Installation VK-T40E



  • Hi Team,

    I recently upgraded by PFsense to the latest release 2.2.2 from 2.2.1 and i started having issues where i couldn't ssh to the box.  Using the diag command line tool i sent "cat /etc/passwd" to query it and it displayed log output and script data back to me.  I then went through other configuration files i new of and they were all looking corrupt so i created a bootable USB stick using the pfSense-memstick-2.2.2-RELEASE-i386.img.  I formated the hard drive and installed a fresh instance of PFsense.

    Now when i boot the VK-T40E it displays "PC Engines APU BIOS build date: Apr  5 2014" as the last line and does not boot pfsense.

    My support has lapsed so i really need some help trying to get this thing working again.  I have tried to roll back to 2.2.1 to no avail which means im doing something wrong clearly.  I do know that i can boot the usb copy but that is it.

    Thanks

    Jail



  • At the end of the installation, did you choose the embedded kernel option?



  • Yes i did select the Embedded Kernel Option :(



  • So i did the install as you normally would then instead of rebooting i returned to the terminal.

    From the terminal i mounted the disk where the new operating system was and add the following to the /boot/loader.conf.local file located in my mount directory

    mount -t ufs /dev/ada### /root/ada###
    vi  /root/ada###/boot/loader.conf.local

    deleted kern.cam.boot_delay="10000"

    added the next 3 lines
    hw.ata.atapi_dma="1"
    hw.ata.ata_dma="1"
    hw.ata.wc="1"

    Then i umounted and rebooted the box cleanly and booted of the 30g mSata disk where i had just installed. Up came the operating system and everything was fine and dandy until i needed to remove the usb stick.

    So i pulled the power on the VK-T40E (dirty shutdown) removed the usb device and then plugged it back in.  Everything appeared to be working fine until it finished booting.  It prompted me for a password then a username and password and none of the defaults worked so i rebooted with my usb stick again, mounted the disk as i had done before and discovered some configuration files in the ETC directory were corrupted.

    So it appears i have hit the https://redmine.pfsense.org/issues/4523 bug which will require me to wait until 2.2.3.  I had seen this issue on 2.2.0 upgrades etc when things such as the wheel group disappeared from the /etc/group directory.  As i have an embedded device i need to ssh to the device and shut it down cleanly or suffer corruption everytime. so beware people :-)


  • Banned

    @jailbreaker:

    added the next 3 lines
    hw.ata.atapi_dma="1"
    hw.ata.ata_dma="1"
    hw.ata.wc="1"

    This has no effect on 2.2.x, read the wiki for proper hints.


Log in to reply