User 1001?



  • Hi all,
    after upgrading from 2.1.5 to 2.2.2 and overcoming several problems i finally managed to have pfsense up and running again.In system logs i came across several errors concerning wrong user rights which prevent me to ssh to pfsense box.I used CHOWN and solved the issue.When i logged in to pfsense box i found out that many directories where owned by user 1001.Is this normal?


  • Banned

    No, definitely not normal. I'd suggest a full reinstall and configuration restore.



  • Have you taken a look at passwd, masterpasswd, group over in /etc to make sure they're ok?  A lot of times the "first user added" winds up at uid 1001, gid 1001.  Maybe a package added a user with 1001?  Taking a look on my system (started out with 2.2.1) I see dhcpd at uid 1002, but nothing at 1001.



  • I did an upgrade and it changed a lot to 1001.  I had to chown -R root:wheel /etc/ in the GUI to get ssh and console to work.



  • Hi, i have the same problem. im run a find / -user 1001 -exec chown root:wheel {};
    this fix almost all the problem, but i need to install mongodb for the unifi controller, when tried to run mongod get a Illegal instruction (core dumped)


  • Banned

    This is NOT the thread to discuss mongodb.


  • Rebel Alliance Developer Netgate

    There was an issue with the update .tgz files that should be corrected now. Forcing another update to the same firmware should be OK, or a wipe+reload is always a solid path to success.


Log in to reply