SOLVED: caused by Virtual MAC+VLAN:Unable to get SLAAC IPv6 on Comcast since 2.2



  • Since my upgrade to 2.2, I've stopped not only getting my PD, but also my SLAAC address for the WAN interface. I've updated to 2.2.1 and 2.2.2 with no joy.

    Current log:
    Apr 21 12:45:30 php-fpm[54705]: /rc.newwanip: ROUTING: setting IPv6 default route to fe80::201:5cff:fe74:4446%em0_vlan999
    Apr 21 12:45:30 php-fpm[54705]: /rc.newwanip: ROUTING: setting default route to 68.–snip---
    Apr 21 12:45:30 rtsold: Starting dhcp6 client for interface wan(em0_vlan999)
    Apr 21 12:45:30 rtsold: Recieved RA specifying route fe80::201:5cff:fe74:4446 for interface wan(em0_vlan999)
    Apr 21 12:45:30 php-fpm[54705]: /rc.newwanip: Could not find IPv6 gateway for interface (wan).
    Apr 21 12:45:30 php-fpm[54705]: /rc.newwanip: Could not find IPv6 gateway for interface (wan).
    Apr 21 12:45:30 php-fpm[54705]: /rc.newwanip: Could not find IPv6 gateway for interface (wan).
    Apr 21 12:45:29 php-fpm[54705]: /rc.newwanip: rc.newwanip: on (IP address: 68.–snip--) (interface: WAN[wan]) (real interface: em0_vlan999).

    I've tried every suggested WAN config for IPv6, tried changing MAC address, etc. Keep getting IPv4 address fine.

    Ideas?



  • Comcast still sucks. Not sure I buy it:
    –-Comcast chat---
    Emmanuel: I was able to verify on my Supervisor. Sir, there are times that IPv6 are disabled as our Comcast developers are updating the covered areas. This the reason why your IPv6 is currently disabled. No worries! You can check the website that I have provided from time to time to know the updates.



  • @JasonTracy:

    Comcast still sucks. Not sure I buy it:
    –-Comcast chat---
    Emmanuel: I was able to verify on my Supervisor. Sir, there are times that IPv6 are disabled as our Comcast developers are updating the covered areas. This the reason why your IPv6 is currently disabled. No worries! You can check the website that I have provided from time to time to know the updates.

    Try to disable Block bogon networks on your wan interface



  • @WiFivomFranMan:

    Try to disable Block bogon networks on your wan interface

    Not necessary on 2.2.2.



  • Solved: The issue was using a virtual MAC address when running PFSense on a single NIC (router on a stick).

    When I was running with the virtual MAC, the NDP table showed my physical MAC still on my external VLAN interface. So, the NDP table wouldn't populate with the MAC of my cable modem.

    When I changed to another virtual MAC, it wasn't fixed.

    When I changed to my physical MAC, it worked.

    The "right" answer is to have a dedicated external NIC, I know this. I'm betting it isn't just the virtual MAC, but the combination of running a VLAN for my external interface AND a virtual MAC.

    What is the best way to submit this bug?


Log in to reply