IP conflict every 24 hour [solved]



  • I have this issue that is most likely of my own making, but I am new to pfSense, and I can't figure out what is causing the issue.

    Every 24 hour my WAN goes down. I have checked the logs, and I find this every time the WAN drops:

    kernel: arp: 0c:c4:7a:36:75:d1 is using my IP address xx.xx.xx.xx on igb0!
    

    I have no idea what this device using my IP address is, but I think it might my ISPs box/router between my fiber modem and pfSense. It is configured to run in bridge mode, and I have not had this issue before. I can't remove the box either, as it is required to split my internet from my TV.

    A reboot of pfSense corrects the issue, and then it takes exactly 24 hours before it pops back up.



  • That's a Supermicro MAC address. Have an IPMI with a shared port? Maybe it's grabbing your IP, which creates the conflict. Something with a Supermicro NIC in it is creating the issue.

    The issue is introduced at your ISP's next hop router, rebooting just sends a gratuitous ARP which lets your WAN NIC take back the IP for a period of time until the other device takes it again.



  • @cmb:

    That's a Supermicro MAC address. Have an IPMI with a shared port? Maybe it's grabbing your IP, which creates the conflict. Something with a Supermicro NIC in it is creating the issue.

    The issue is introduced at your ISP's next hop router, rebooting just sends a gratuitous ARP which lets your WAN NIC take back the IP for a period of time until the other device takes it again.

    Super, that appears to be it!

    I am running a supermicro A1SRi board with a physical management port, but it was not connected to anything. I hooked it up to the switch and identified the MAC address. Appears to be a setting in the web interface with for the network port with options such as "failover", "dedicated" and "shared". It was currently configured in "failover" mode. I suppose the issue might have been fixed now that it receives a proper IP by DHCP, but I'll switch it to "dedicated" anyway.

    Thanks.


Log in to reply