[SOLVED] Unable to communicate with https://packages.pfsense.org (new idea)



  • Hello,

    I know there is already a few topics about this.
    But i'm not sure it is an IPv6 related problem.

    I tried something today.
    We have a multi-wan (failover) configuration, with a lan+wlan bridging.

    I have 2 boxes, a production and a spare one with pfSense 2.2.2.
    First one is an APU, and the second is an Alix 2D13, with almost the same configuration (copied from Alix to APU).

    The main difference (except CPU and RAM) is that the first one has a wifi interface and the second don't have it.
    So, they have the same configuration, except for the missing bridge and wifi interface on the spare box.

    APU has a 16 Gb SSD and Alix a 4 Gb CF Card, so /etc is readonly on this one.

    On the Alix, I have the error "Unable to communicate with https://packages.pfsense.org".
    On the APU, it works fine.

    On both of them, i can ping and resolve packages.pfsense.org from pfSense.

    Remember, they use the same WAN links (plugged on the APU or the Alix box) and have the same configuration with IPv6 enabled (but no ipv6 address on LAN) and preference for ipv4 over ipv6.

    So, I can't explain why one can download packages and the other can't.

    Any idea ?



  • What if you go to a command prompt on the ALIX, via SSH or serial console, and run:

    fetch https://packages.pfsense.org
    

    what's the result?



  • Damn, should have tried :(

    I'm on vacation for 9 days, i'll try asap.
    Not my best idea to create this topic before going away from work  :-\


  • Netgate Administrator

    The apu would normally be 64bit while the alix is 32bit only. Is that the case here?

    Steve



  • Yes, that's indeed the case.



  • It's the same package list either way, 32 or 64 bit. My suspicion was having the default v6 preference and having non-functional v6 on the ALIX for some reason. But sounds like you have it set to prefer v4, so that shouldn't be the case.



  • Ok, i tried again today, enabling the 2 boxes and it works fine on APU and Alix.
    So, I don't know why it didn't worked before, as i didn't change anything.

    Anyway, it works well, pfSense is a really great solution :)


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy