Reiniciando PfSense todo dia



  • Pessoal,

    Depois que atualizei o pfsense pra versão 2.2.1 e atualizei o squidguard e squid, todo dia eu tenho que reiniciar o servidor, se não, ninguém navega pelo proxy.

    Uma coisa que acho estranho, é que a internet funciona acesso externo. Consigo acessar meus servidores que passam pelo firewall/nat e a OpenVPN funciona normalmente também.

    Alguém pode me dar uma luz ?



  • Tive o mesmo problema, vi que tinha a ver com o traffic shapping (limiter) e o squid… ai voltei à versão 2.1.5 ...



  • Estou com mesmo problema, voltei a versão antiga



  • Antes de voltar a versão, tente um restart no serviço do squid ou ver se o log alerta alguma coisa. Tenho squid funcionando na 2.2 sem precisar desses reboots.



  • Marcelloc,

    Já fiz isso e mesmo assim não consigo identificar nenhum problema. Depois que reinicio no inicio do dia, funciona normalmente até o final do dia. Só que no dia seguinte, ou seja, 24h depois.. eu tenho que reiniciar, se não quem estiver com o proxy ativado não navega. Mas funciona OpenVPN, firewall, tudo normalmente.

    Eu percebi isso depois que eu atualizei a versão…. Mas pode ser até alguma configuração, o que eu acho dificil. Eu olhei no LOG do squid e não acho nada.



  • verificou tarefas agendadas no cron ?



  • Na proxima tente só matar os processos do squid e salvar as configurações novamente para ver se não precisa do restart.



  • 2.2.1-RELEASE (i386) , com squid 2.7 + squidGuard, todos os seus problemas vão acabar. Piece.



  • @luiz.bsb:

    2.2.1-RELEASE (i386) , com squid 2.7 + squidGuard, todos os seus problemas vão acabar. Piece.

    Luiz, a 2.2.2 já saiu, o squid 2.7 é velho e descontinuado e a versão i386 só é recomendado para máquinas que não aceitam a versão 64 bits.

    Não sei qual foi seu trauma com o squid3 + pfSense amd64 mas o que está sugerindo é um retrocesso.



  • Tenho vários pfsense usando 2.2.1 e 2.2.2 com o squid3+squidguard e não preciso ficar reiniciando. Tive problemas com o squidguard de ficar usando todo o processador mas ao fazer o download da blacklist resolveu.



  • Marcello, desde o dia que postei esse post, estou com esse problema de ter que reiniciar o servidor do pfsense se não ninguém navega quando chegam pra trabalhar. Estou a 1 mes procurando uma solução. mas ainda não encontrei. Alguém sugere alguma coisa ? Não posso levantar outro server e trocar… muito retrabalho e sem maquina pra isso



  • cara tem certeza que o serviço do squid não está parado? 
    Pq estou tendo um problema parecido, quando chego na empresa vejo que o serviço squid está parado. Por conta disso ninguem navega se tiver com o proxy setado.

    Percebi que este problema começou a acontecer depois que habilitei a opção "Clear cache on log rotate" em Proxy Server > Local Cache (Cache management)

    bom, mas nao sei se meu problema é igual o seu..  estou testando desabilitar a opção que usei acima.



  • Estava com esse problema, pfsense reiniciando periodicamente em um intervalo de tempo aleatório.
    Depois de muitos testes, era uma placa de rede que estava danificada…





  • No meu caso eu creio que seja problema na configuração de TIME no squidguard, pois meus usuários que não tem restrição de hora navegam normalmente todo dia. Somente os usuários restritos por horário é que tenho que clicar no botão de apply no squidguard para que ele libere a navegação, já coloquei a linha no cron:

    0  4  *  *  *  root  /usr/pbi/squidguard-i386/sbin/squid -k reconfigure

    Mas sem sucesso, todo dia tenho que clicar no botão apply do squidguard para o mesmo entender o esquema de time.



  • Uso o versão 2.2.4, o problema está no  SQUIDGUARD, ao desinstalar estes o Firewall para de reinciar.



  • BOM DIA, feras

    alguém poderia fornecer o link ou compartilhar a versão do pfsense 2.2.2 comigo