Installing pfSense 2.2.2 on Netgate RCC-VE 2440



  • I'm trying to install pfSense on my Netgate RCC-VE 2440, but cannot get the memstick to boot. After POST, the console stops at

    
    Booting from Hard Disk...
    Booting from 0000:7c00
    
    

    Image used: both pfSense-memstick-serial-2.2.1-RELEASE-amd64-20150313-0816.img and pfSense-memstick-serial-2.2.2-RELEASE-amd64-20150413-2010.img

    Image written to disk with physdiskwrite, and USB stick boots on a laptop.

    According to pre-installed CentOS, the USB serial console port is registered as COM/ttY1 - is the installer trying to send output to COM/tty0?

    Any pointers to what I do wrong would be much appreciated  :)



  • You have to use the ADI RCC-VE memstick. It's since been added to the download selection page.
    https://www.pfsense.org/download/mirror.php?section=downloads



  • Thanks for the tip - I'll try that image now!



  • I got this working only with Putty under windoze as a serial console.
    All others I've tried: screen, CoolTerm, serialTools on Mac give me garbaged output: Not able to render curses coloured UI, text progress bar makes for unreadeable UI.

    Any idea how to fix this, so I can connect from some *Nix to the serial port? ( This is not really specific to RCC-VE 2440 I guess )



  • For OS X, the best way I have found to have reliable, drop dead stupid serial emulation is to use Serial https://itunes.apple.com/us/app/serial/id877615577?mt=12. Supports all the various terminal types and several of the most common USB to serial adapters without requiring drivers. I have used it with both a PC Engines APU4 and now a pfSense SG-4860.



  • The ADI image did the trick, but as clusty I got messy install-menu. Was able to complete install, so only minor inconvenience.

    What I have tested with 2.2.2 so far:

    • Install to and boot from mSATA disk
    • 802.11N WiFi (WLE200NX)


  • @clusty:

    I got this working only with Putty under windoze as a serial console.
    All others I've tried […] give me garbaged output

    Coming from a Windows world myself I know what you're saying. Been there, …
    There's puTTY for OS X which works reasonably well (but needs X11).
    Currently I use ZOC in OS X which works great. I also have a Win7 VM where I use Tera Term frequently.


Log in to reply