[SOLVED] LAN1 to LAN2 routed wrong + diagram



  • Hey everyone!

    I have a specific problem with Pfsense that route the internal network request away instead of using the directly connected networks. I have tried to explain the situation as much as detailed with a detailed diagram. LAN1 communicate with LAN2 , but LAN2 does not communicate with LAN1. If anything unclear from the picutre/diagram please let me know so I can explain. Basicaly the internal network requests is send to the WAN, by using the hostname+domain.

    Purpose: last year we had 20 VoIP phones and 30 PC's, and everything worked fine. But now we got 50 VoIP phones with 60 PC's + 40 devices. we have 50% broadcast traffic and we decide to separate the VoIP traffic with another network.
    What have been done : I have add the rules,NAT, static mapping, TFTP, DHCP.. moved the VoIP server and phones there. The trunks got registration back and become online too phones get the right configuration start communicate with the server, nicely perform calls and hear them BUT! The sound is not send out even with internal calls.

    Whats the outcome from the topic: If this start working I should be able to communicate with the VoIP server from the other LAN with a phone and start troubleshoot the other aspects of the issue, because something is configured wrong and I dont know the exact reason, DHCP, DNS ? no thing in the System Logs, so it configured that way!

    P.S. I am using pre-build pfsense from someone else and I dont know what option/configuration is causing this.


  • Banned

    Post the screenshot of the default LAN configuration and netstat -rn output.



  • I guess you might have policy-routing rule(s) on LAN that are forcing the traffic out the WAN.
    So also read this post I just made on the same topic: https://forum.pfsense.org/index.php?topic=92731.msg515205#msg515205

    and also answer doktornotor!



  • And the credit goes to phil.davis ! You hit it right in the center :D
    The problem was exactly like phil.davis said. The Load_Balance rule matched first and that "force" the gateway to search for local IP address in the open ocean.
    Silly me that I did not though about it, so much pfsense things that I even got confused at the end :D You bring me back on track! Thank you very much again, I will post now screenshot of how rules should be as follow!





Log in to reply