Pfsense randomly and repeadidly locking up - Solved!



  • Hello all, I have a problem with the PFSense software on a computer that is running my network. I have used this computer for about 1 year with m0n0wall just fine. I found PFSense and it sounded like a worthwhile upgrade. I downloaded the PFSense and put it in the computer that is running my network. The computer is booting from CD, and is saving to a floppy. I backed up the m0n0wall config before I did anything so I have a fall back. I formatted the floppy when I changed to PFSense, and then re-entered my settings from scratch. It ran just fine when I went to bed, and when I woke up the computer had locked up with a kernel panic. I had to hard boot it, but it came back up. When I came back from work it had done the same thing. I rebooted it, and it worked again. When it crashes I loose internet and network access. The computers also loose their IP address if I change anything while its down. I just went back there and found this on the screen: "acd0: FAILURE - READ_BIG MEDIUM ERROR asc=0x02 ascq=0x87 vm_fault: pager read error, pid 534 (lighttpd)". I have reburnt the disc 3 times on different discs. I tried cd-r and cd-rw. The computer runs m0n0wall with no errors and has not crashed once in the year I've been running m0n0wall. From all the documentation it looks like PFSense is built on the same basic kernel.

    The computer is a Gateway Performance 1300, with a Intel Pentium 4 at 1.3GHz, 384MB of RDRAM, no HDD, CD-RW optical drive, Dual Netgear 10/100 PCI NICs. Its connected to Comcast HSI, 8800/768 kbps, and there are about 8 devices on the network.

    Also, when I get the error I am unable to get to the WebUI. If I restart the computer everything works for a while, then it goes wrong again. What could be the problem?



  • you can't really compare m0n0wall and pfSense but from what it sounds you have problems with the cdrom. m0n0wall runs from a ramdisk once it is booted up and will never again access the cdrom until the next reboot. You might just have been lucky with m0n0wall therefore. If the problem doesn't occur on bootup m0n0 will be fine. it's different with pfSense. I would try with another cdrom drive. also note that the stable versions of m0n0wall are still based on freebsd 4.11 and only the beta branch 1.3 runs a similiar kernel like pfSense.



  • Thanks Hoba, I kinda of had a feeling that it might be something with the CDROM, but I wasn't 100% sure. I have found another suitable drive and replaced it. The computer booted into pfsense just fine, but we will see if it crashes tonight. I am also going to move it to a hard drive when I can get one cheap or free that is large enough, and isn't dead.  ;D  Side note, I found a 350MB Quantum drive in an old box with MS DOS on it!  ::) ;D



  • Get an ide to cf converter with a cfcard or a DOM (sidk on module) or if the hardware supports it you even could run from a usb stick. Less power, less noise and much more reliable than an old 350 mb hdd. I don#t want to hear that pfSense crashes again when running from this dusty brick of harddrive  ;D



  • Well, after 24 hours the box has not crashed. I think changing out the CD-ROM for another worked. Its just as solid as the m0n0wall was.

    The 350MB drive works fine, but the installer rejects the drive!  ;D ;D I think this is due to size. The computer boots to DOS just fine…

    I have a 6GB Maxtor that died sometime between when I put it in the basement and now, so its gone.

    Getting an IDE to Cfcard involes buying stuff, and I am trying to avoid it. However, this might be worth the expense as I could just have the slow moving CPU fan and have a very quiet box.



  • Don't forget, that a cfcard consumes much less power so it starts to pay back after some time and cards and adapters are pretty cheap nowadays.



  • Ok, I am happy to report that everything is working as it should, except for one thing. The RRD Graphs no longer work. I have rebooted the machine, but nothing. They did work before I changed out the CD-ROM, but now the WAN side reports nothing. The LAN side reports everything correctly. Is there a way to correct this?



  • The rrd database is stored on the floppy on scheduled reboots (either initiated by webgui or from the shell). If you want to reset  the rrd graphs shut down the system, delete the rrd database from the floppy and fire up the system again. It will regenerate the rrd database from scratch then.



  • Ok, I have since moved the install to a hard drive setup. I found a 10GB Quantum Fireball that works great. I will consider a CFcard when/if the drive dies. The rrd graphs worked when I was running the floppy, but I moved everthing over durring the install and now they are giving me an error.

    "There has been an error creating the graphs. Please check your systemlogs for further details."

    I checked the logs and found "kernel: pid 28071 (rrdtool), uid 0: exited on signal 11 (core dumped)"

    I guess I should remove the drive, erase the rrd database and hope it rebuilds it from there. Other than the rrd graphs the machine is very stable and runs great. It boots up soo much quicker on the HDD than it did on the optical drive (as it should).



  • So, after searching around I found out how to reset the graphs now that it is on the hard drive. I am happy to report everything is working 100%. Thanks for the help, and now this thread can now be closed.  ;D


Locked