SG-2440 console access



  • Got a new SG-2440 delivered this morning.  Great.  Booted, and accessed via 192.168.1.1

    Restored with my present pfsense firewall config, and voila - no access.  Reset doesn't seem to work even after numerous reboot while pressing reset as described in forum.

    To save the non-engineers, here is how to now access your console on the SG-2440:

    Used Windows 7 laptop because it was there:

    1. insert mini-usb cable into console port and to your laptop
    2. install  USB to COM bridge driver as per:
      @mwp821:

    Yes, that's right, and you'll need this driver: http://www.silabs.com/products/mcu/Pages/USBtoUARTBridgeVCPDrivers.aspx

    1. find your com port -> Control panel -> Hardware & Sound -> Devices -> Device Manager -> Ports
    2. locate Silicon Labs USB bridge COM listing
    3. boot firewall
    4. fire up Putty -> serial, 9600 (worked for me, others said 115200) com5
    5. if blank screen, Enter
    6. should now give you the main pfsense console.  If not, try rebooting firewall

    factory reset or configure as wanted.

    Other options include using a USB to Serial -> com1 port on PCBSD/FreeBSD or Linux workstation.  Use minicom, tip, or cu to access

    Good luck


  • Netgate Administrator

    Hi, great to see you're up and running again.
    For reference the factory default console speed is 115200. It's likely that your old config had a serial speed of 9600 defined in it which is why it appeared at that rate after reboot.
    If you do reset to factory defaults from the console it will change back to 115200.

    Steve



    1. fire up Putty -> serial, 9600 (worked for me, others said 115200) com5

    And one on top by me, Putty, the SG console and pfSense should have the same speed
    to get a read able output. So if the standard or default of pfSense will be 115200 it would
    be good to set up the same at the SG device and Putty.



  • @BlueKobold:

    … it would be good to set up the same at the SG device and Putty.

    No, it's mandatory.


Log in to reply