DNS lookup fail with DNS Resolver but work with DNS Forwarder. Fresh Install.



  • Fresh Install of pfsense 2.2 on a Dell Poweredge Server with dual NICs.

    DNS resolution failed out of the box for all clients behind the pfsense box with DNS Resolver running, stopped it and started DNS Forwarder and DNS resolution worked but it's not using the OpenDNS servers I specified in System –-> General Setup. I also have "Allow DNS server list to be overridden by DHCP/PPP on WAN" unchecked.

    How do I fix this so DNS Resolver works and uses OpenDNS for name resolution?



  • It's my understanding that Unbound (DNS Resolver) uses the root servers for resolution and will ignore what you have entered on System > General > DNS. This is the intended behavior of Unbound. So make sure you have good connectivity via your default gateway to those root DNS servers.  If you want a more "traditional" mode similar to dnsmasq (forwarder), then either switch back to that or go to Services > DNS Resolver > and enable the checkbox "Enable Forwarding Mode" -  save & apply and test again.

    If still not working post screenshots of your LAN/WAN firewall Rules as well as System > General, Routing, and Unbound config pages.


  • LAYER 8 Global Moderator

    "How do I fix this so DNS Resolver works and uses OpenDNS for name resolution?"

    Simple troubleshooting.  So can your client behind pfsense query opendns?  Can your clients behind pfsense query the roots?  Or any other name servers?

    What do you have the resolver listing on?  Are you really using the resolver or do you have it in forwarding mode?  Can pfsense?


Log in to reply