Anybody using SIP phones to external provider through SIPROXD?



  • I would vere much like to use siproxd agains my sip provider (viptel.dk), the two current phones we have are RTX SIP Du@lphone and Linksys Sipura 901. They are both connected directly to a public IP, I would love to have them protected behind my firewall.

    I tried fiddling around with the siproxd and the Sipura, but as I don't know much about SIP, I couldn't make head or tale of things, and I couldn't make it work.

    Anybody that has a 'dummies' guide to do this somewhere? Or even a setup with another phone that works?



  • I don't know if you solved your problem, but usually provider will provide a outbound proxy, you just have to set it up in your ATA and you're good to go. I have my ATA with two FXS registered to two different provider and they both work just fine behind pfSense, but they use the provider outbound proxy to work. I didn't had to make any port forward to make it work.

    BUT, here is the catch, if you would like to have the possibility to receive inbound sip call directly to your device, ie: someone dial <your_phone_number>@ <your_ip_address>that won't work behind pfSense, even if you setup NAT. To be able to do this you will need to install and configure the package "siproxd" as you figured out, but unfortunately I can't help you very much since I can't install it on my embedded installation of pfSense. If it's like the FTP Helper, the siproxd only rewrite the sip header packets and keep track of everything. Your ATA should as usual connect to your provider, but this time disable the outbound proxy since you can receive connection. When you have the siproxd configured you will need to have port 5060 NATted to your ATA #1 and port 5061 to ATAT #2 and so on… Then the direct SIP dialling will work.

    Edit: But it's different than FTP Helper, read the forum to set it up ... It's more like a local sip proxy ... I still believe that you have to create the NAT from WAN to LAN to your devices to receive URI SIP Dialling.</your_ip_address></your_phone_number>



  • I just got mine working. Here's a link to my post:

    http://forum.pfsense.org/index.php/topic,10084.0.html


Log in to reply