[RESOLVIDO] PFSense 2.1.5 +Squid +SquidGuard +GrupoLdap = não funciona



  • Pessoal, boa tarde. Estou tentando configurar o PFSense com proxy autenticado, gerenciando por grupo do AD. Porém, não funciona.
    Segui o tutorial informado por outro colega aqui no forum (http://www.dev2infra.com/pfsense-squid-squidguard-autenticacao-transparente/), incluí como membro do domínio o pfsense, autentico nas configurações LDAP do SquidGuard com usuário utilizando senha 'normal' (sem caracteres especiais). E nada.
    Ele sempre lista como Client group: default (na página de bloqueio).

    Dados:
    Versão PFSense: 2.1.5 com samba instalado por script disponibilizado aqui no forum (perdão pelo esquecimento do autor);
    Windows Server 2008 R1 Standard
    Grupo com nome Liberado criado em OU Users
    Proxy Filter (General Settings): LDAP DN = "cn=squid,cn=Users,dc=dom,dc=local"
    Groups ACL -> Client (Source):
    ldapusersearch "ldap://192.168.100.1/DC=dom,DC=local?sAMAccountName?sub?(&(sAMAccountName=%s)(memberOf=CN=Liberado%2cOU=Users%2cDC=dom%2cDC=local))"

    As target rules estão configuradas.
    Obrigado!





  • Opa! Nada feito. Continua não aplicando a regra. Mesmo tendo recriado após a alteração.



  • Resolvido. Após refazer algumas vezes, percebi (ao menos na ultima tentativa) que o erro estava no usuário de autenticação e pesquisa ldap. Como criei com sobrenome, o CN do mesmo ficava nome + sobrenome. Após alterar para somente com nome, funcionou de boa (configurado como LDAP. Não testes NTLM).
    Obrigado!