Stuck on upgrade from 2.1.5 to 2.2.2



  • hi,

    I'm running pfsense 2.1.5 on freebsd 8.3-release-p16 on a vmware esxi 5.5 and want to upgrade it to 2.2.2..
    I followed the upgrade instructions found on https://doc.pfsense.org/index.php/Upgrade_Guide
    means that I removed all my installed packages, and click than the "Click Here to view update." button on the WebGUI and start the upgrade process..

    I've opened the vm console to see whats going on, when I start the upgrade process it shows me "Firmware upgrade in process" and the same is shown on the webGUI.. I can wait for 12 hours, and nothing happens..

    any idea what causes this issue?


  • Banned

    Probably nothing will happen at all due to a known bug. You can just reboot and retry the upgrade again,  roll back to recent VM snapshot and try again, or just do a fresh 2.2.2 install and restore the config.

    https://redmine.pfsense.org/issues/4653



  • I've no succesfully updated to 2.2.2 on freeBSD 10.1

    I've restarted the pfsense, removed all installed packages, removed the captive portal instance, then I've started the upgrade process.. it stuck again, but I restartet after 20minutes with shutdown -r in linux shell, after this I've installed all my packages again, but now I'm not able to start the packages "c-icap", "havp", "mailscanner", "postfix forwarder".. this is what maillog says:

    May  8 14:29:55 pfsense MailScanner[54948]: Connected to Processing Attempts Database
    May  8 14:29:55 pfsense MailScanner[54948]: Found 0 messages in the Processing Attempts Database
    May  8 14:29:55 pfsense MailScanner[54948]: Using locktype = flock
    May  8 14:31:27 pfsense MailScanner[36560]: MailScanner child caught a SIGHUP
    May  8 14:31:27 pfsense MailScanner[7631]: MailScanner child caught a SIGHUP
    May  8 14:31:27 pfsense MailScanner[20280]: MailScanner child caught a SIGHUP
    May  8 14:31:27 pfsense MailScanner[98700]: MailScanner child caught a SIGHUP
    May  8 14:31:27 pfsense MailScanner[54948]: MailScanner child caught a SIGHUP
    May  8 15:45:40 pfsense postfix/postfix-script[22754]: fatal: the Postfix mail system is not running
    May  8 15:45:43 pfsense postfix/postfix-script[44921]: fatal: the Postfix mail system is not running

    after I tried a few times to start the services..

    any further ideas what causes this problem?


  • Banned

    I already linked the bug. Do a clean install and move on. Really a no brainer with VMs.


Log in to reply