Another Watchguard x750e Thread - BIOS not flashing

  • I recently bought a pair of x750's and am attempting to get pfsense onto them.  One came with a 512mb CF card, the other with a 256mb.

    I've only tried the 256mb-model so far, but I cannot seem to get the BIOS to flash.  I have stephenw's version of FreeDOS with three different BIOS versions on, and have tried flashing them all.  The first hangs, the second and third return to the command prompt after 4-5 seconds.

    When I reboot, I cannot see the BIOS POST info (even at 115200bps), and when I get back into FreeDOS, I re-run the biosid utility only to find that the BIOS version is exactly the same as before I attempted flashing.

    Needless to say, the 4GB CF card with pfsense on it doesn't boot.

    Has anyone come across this problem before?  Anyone got any ideas what I'm doing wrong?

    *** Edit ***

    The second Watchguard behaves in the same way.  It boots fine from the smaller CF card (which is actually 128MB, not 256, my mistake), loads up FreeDOS and allows me to run the awdflash util, but doesn't appear to do anything.

    Does anyone have biosid output from after they flashed a newer bios, does the version / BIOS date change?

  • Hi,

    Are you trying to flash the B8.1 Bios?

    I would suggest you try the B7 Bios first.

    If that flashes you may have a 1MB chip instead of the 512k that the bios expects.

  • Netgate Administrator

    Yes, you may have the 1MB rom chip.
    If you backup the existing BIOS ROM what size is the resulting file?


Log in to reply