It seems pfSense (or FreeBSD) takes over the serial port on boot…



  • So, I am working on getting NTP setup with a Garmin gps unit. So far everything works perfectly until I reboot the machine.

    If I leave the GPS plugged into the serial port when the machine reboots, during the NTP start up it will hang the system. I can disable NTP, reboot, and try to use gpsmon to connect to the GPS which will also hang the terminal.

    Now, If I unplug the GPS when the system boots up, then plug it back in after its booted both gpsmon and NTP will work flawlessly.

    All this leads me to believe that it is a issue with FreeBSD or pfSense "taking over" the com port during boot.

    I have double checked to make sure serial console is disabled in the webgui and I have tried to change a few settings in the /boot/loader.conf:

    • changed 'boot_serial="YES"' to 'boot_serial="NO"'

    • changed 'comconsole_speed="115200"' to 'comconsole_speed="4800"' to match my gps speed

    • added 'console="vidconsole"'

    None of that seemed to work and I have no idea what else to try. :( Please HALP!



  • Try just deleting the boot_serial and comconsole_speed lines from /boot/loader.conf.
    Do you have only one serial port? Maybe you have a second one on the motherboard directly, try to use that.



  • I've tried using just the single on board then I added the 2nd one and tried with it also.. I'll remove those lines and see what happens..