[RESOLVIDO]Problema com Squid3 + Squidguard no PFSense 2.2.2



  • Foi implementado o PFSense na versão 2.2.2 e Squid3 [0.2.8] + Squidguard [1.9.14]ao iniciar o Firewall o serviço dos dois não inicia, somente volta após ir em blacklist e realizar o download. Alguém pode me ajudar?



  • Olá,

    Em relação a esse tópico realmente é necessário criar uma categoria em Proxy filter no squidguard. Criei e reiniciei o Firewall e os serviços iniciaram normalmente.

    Obrigado



  • Olá….

    Perfeito Funcionou, apenas para auxiliar na busca, porque demorei para achar pois não buscava por esse erro e sim pelo debug (squid -d).

    kid1| WARNING: redirector #Hlpr0 exited FATAL: The redirector helpers

    Este era o erro.

    att



  • O problema ainda persiste.

    Detalhe que no meu cenário foi atualizado do 2.1.5 para o 2.2.2 e acredito que muitos estão com o mesmo problema.

    Alguém ja conseguiu algum progresso ?



  • ola

    meu tambem era 2.2.1 e foi atualizado para 2.2.2.

    mas o procedimento funcionou

    att



  • No meu caso fiz o procedimento e não funcionou.

    Porém já tinha muitas categorias criadas.



  • quando você executa "squid -d 0" você obtem o mesmo erro que eu tinha.



  • O Squid3 somente, funciona perfeito e ao ativar o Squidguard, ambos param de ser executados.

    Neste momento estou testando uma alternativa de contorno e retornarei em mais alguns momento.



  • PESSOAL entrei no SHELL e fiz o limpa nos diretórios do Squid3 e SquidGuard.

    Reinstalei e voltei o backup, tudo funcionou legal.

    Acredito que todos que forem dar UPGRADE das versões 2.1.X (fiz da 2.1.4 e 2.1.5 e ambas apresentaram o mesmo problema), terão esta falha, logo se cuidem.

    [RESOLVIDO] vlw abraço e fui.