Check_reload_status using 50% of CPU



  • pfSense 2.2.2 64-bit on a VK-T40E. 
    I noticed in my normal checks on customer firewalls, one of them has 51% CPU utilization.  I checked the RRD graph and it's been going on throughout the weekend.

    I SSHd in, and ran top.

     264 root        1 122   20 19032K  2036K CPU1    1 161.8H 100.00% check_reload_status
    71158 root        1  22    0   232M 35096K accept  0   0:00   1.66% php-fpm
    73009 proxy       1  20    0  1164M  1028M kqread  1 324:47   0.10% squid
     2443 root        1  20    0 21732K  5028K select  1  48.8H   0.00% openvpn
    30602 nobody      1  20    0 30260K  3824K select  1  30:40   0.00% dnsmasq
    25913 root        1  20    0 12464K  1816K select  1  18:10   0.00% apinger
    75422 proxy       1  20    0 26428K  2840K msgrcv  1  10:15   0.00% diskd
    30016 root        1  20    0 54896K  8344K kqread  1   7:51   0.00% lighttpd
    35055 root        1  20    0 55732K  6812K bpf     1   5:15   0.00% bandwidthd
    
    

    I tried to kill PID 264, but it won't die.

    Anything else I can look at, before I schedule a reboot?



  • I found a thread that related to 2.1.5 stating that check_reload_status eating 100% of a CPU was indicative of something else being amiss.  I checked my gateways, and none were showing down.  I don't think I have any flapping interfaces, either.

    Nobody is complaining about performance yet, so I'm not terribly concerned.  I just don't want it to get to that point.

    Any help will be appreciated.



  • could try to restart apinger service from gui



  • Restarted apinger.
    No joy.
    :(



  • Restarted other services, still no joy.
    I'm at a loss as to what else I can do, save a reboot.



  • Rebooted.
    Processor utilization back to normal.

    My Death Star phone company PPPoE DSL connection may have been a contributing factor.  I have disabled it for now.