System shutdown - every second command reboots the machine



  • Hi,

    I run pfSense 2.2.2 on two DELL R210 II, BIOS 2.8.0.
    As I tested shutdown command to shut off the machines in case of power failure at low UPS battery, I found out that the machines reboot on every second shutdown command. The other times it keeps off.

    I've tested it with different command like halt -p, shutdown -p now, poweroff. It's the same with each of them.
    It's also the same if I call halt from the console or GUI.

    I'm not sure if it is a hardware issue. However, I have tested the shutdown also with Kanotix and Win 7 and here it works.

    Can anyone confirm, this happens on specific hardware?


  • Banned

    Sounds like shitty BIOS to me…



  • Yes. That was my first thought too.
    However, if that's the reason I can't see, why the unrequested restarts don't occur with Linux and Windows.

    The BIOS is the current version.


  • Banned

    Probably because someone worked around it in Linux kernel/some shitty Windows driver supplied with the MB to work around their junky BIOS/ACPI?