Fresh load (2.2.2 x64) - doesn't see SMI AOC-SG-i4 Quad GBit NIC



  • Good afternoon.

    Now, it's been a while since I used this card on PFSense (like 2.0 days), but I recently tried to put back in my SuperMicro AOC-SG-i4 Quad Gigabit NIC and make a new appliance with a fresh load of 2.2.2 (x64), but it doesn't see the quad card.  It identifies the two on-board GigE interfaces, and thus auto-assigns them to lan/wan, but doesn't see the expansion card.  I assumed this meant there's no driver for it, but it seems odd the driver would have existed in a previous release and been removed later.

    Has anyone else had an issue with this card?  I'm really confused because the PFSense store sells a very similar card (its just the short version).  Is there any easy way to switch what drivers the installer uses, or is there some Advanced Install I can execute that will make it identify the card properly?

    TIA.

    Kris



  • You can try this, not sure if it would help:
    https://forum.pfsense.org/index.php?topic=89057.msg492375#msg492375



  • Well, I had hoped that would be a wonderfully easy fix, but sadly no.

    I tried both options listed there (adding the local boot option and the system tunable). :(



  • I've confirmed this card should be utilizing the IGB(4) driver, per this thread:
    https://forum.pfsense.org/index.php?topic=61031.0

    Though the thread discusses the 2-port version of this card, they both use the same chipset.  This also explains why it used to work for me - as something has changed since the 2.0 software variant.

    I know the card works because the same hardware (loaded with Windows) sees/utilizes the NICs.  Additionally, on boot the PXE agent tries to boot off each of the 4 ports.

    Whatever it is, it's specific to the 2.1/2.2 versions of PFSense, which is not good. :(



  • https://communities.intel.com/message/104432

    i read in another post elsewhere, that it might help if you could somehow force your pci-express to 'gen1' somewhere in bios



  • STARRED THIS - It wasn't directly the solution, but it got me on the right track.

    BIOS had the Gen1/2 option (default was AUTO), but forcing a specific setting had no effect.

    What DID have an effect was the BIOS option to enable PCIe - Default was AUTO, and I had expected it would default to active - but apparently…. not so much.  When I forced it to enabled, it showed right up.

    So, THANK YOU!!!!!!