Interfaces not working on 2.1.5 and 2.2.2



  • I have a test 64-bit router in my lab environment that was running 2.1.5 and had been upgraded to 2.2.1 in the past.  It had been sitting on the shelf for a few months and I have some new testing to do, so I pulled it out and reinstalled 2.1.5 after booting from the memstick image on a USB stick.  Everything seemed to go well until the interfaces were assigned after the install.  It did the auto-assign process and in that assignment process it detected that the interfaces came up, but after rebooting the router the interfaces wouldn't respond to pings, no traffic was being routed, etc.  I also can't pull up the web interface, and DHCP devices were unable to get DHCP addresses even though DHCP had been enabled on the LAN interface.  When looking at the VGA console, it isn't even showing a message when the LAN or WAN ethernet cables are being unplugged or plugged in.  This is particularly weird because we've run 2.1.5 on this test box before.

    So I installed 2.2.2 to see if that does better, and it does the same thing.  At that point we suspect hardware failure, so we order a new Supermicro box (also 64-bit) with additional Intel 4-port NIC that is the same type as some of our production boxes running 2.1.5 (the previous box was a different model with different MB, NIC, etc.).  It ends up doing the same thing on both versions.  We even tried installing both 2.1.5 nano and 2.2.2 nano on USB and booting off that, and it also does the same - after the auto-detect of the interfaces for WAN and LAN, it won't show any activity for either interface.

    We found a problem with Intel NICs sometimes exhausting mbufs at https://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards, and in the internet HD-installed version we tried changing the entry in /boot/loader.conf.local that they reference.  It didn't make any difference.  The other test routers in my lab setup are also Supermicro, almost identical in hardware, and they are working fine still (and I was able to upgrade them to 2.2.2 with no issues).

    Anybody have any suggestions?  It sure sounds like the article we referenced, but the fix listed isn't working.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy