LAN on Dell 2900 not starting



  • I installed PFsense 2.2 on an old Dell Poweredge 2900.

    It is running fine, but I have one issue.

    After starting the server the lan network card (BCE0) is not working. I can not ping the server or ping from the server to another internal IP address. According to the console screen the network has the correct IP address.

    To get the network card working I have to reassign the IP address using option 2 at the console. I gave it the same IP address as it has (192.168.0.1 /16).
    After a few seconds I get the following message:

    kernel: bce0: /usr/pfSensesrc/src/sys/dev/bce/if_bce.c(7869): Watchdog timeout occurred, resetting!
    

    Waiting again a few seconds and the network works.

    During boot the following messages pops up in the log.

    
    kernel: bce0: <qlogic netxtreme="" ii="" bcm5708="" 1000base-t="" (b1)="">mem 0xf4000000-0xf5ffffff irq 16 at device 0.0 on pci9
    kernel: bce0: /usr/pfSensesrc/src/sys/dev/bce/if_bce.c(1247): Management firmware enabled but not running!
    kernel: bce0: ASIC (0x57081010); Rev (B1); Bus (PCI-X, 64-bit, 133MHz); B/C (1.8.0); Bufs (RX:2;TX:2;PG:8); Flags (SPLT|MSI|MFW); MFW (NOT RUNNING!)
    kernel: bce0: bce_pulse(): Warning: bootcode thinks driver is absent! (bc_state = 0x00000006)</qlogic> 
    

    I made the changes to the bootloader mentioned in:
    https://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards#Broadcom_bce.284.29_Cards

    Problem seems only to exist on bce0, bce1 (connected to the router) seems to be good.

    Can this be a hardware malfunction?

    Edit:
    Installed latest NIC firmware and Dell Bios.
    Didn't help



  • Just a guess on my part, but I recall some of those Dell's having IPMI available.
    Perhaps a conflict w/IPMI wanting direct access to that NIC?

    I've had good success adding dual port Intel PCIX Nics to the Dell 1900 series, they're available fairly cheap all across Ebay.
    Might be an option…...



  • Do like to find out more.



  • Sometimes life is to easy  :-\

    Bios to default settings seemed to fixed the issue..