Multi-WAN problems with proxy



  • I struggle to set up squid3 on my system and run into the issue that only the default gateway is used. I have 3 WAN interfaces and 1 LAN and there are numerous firewall policies to make sure always the appropriate WAN gateway is used for a certain host, destination address etc.
    There is no loadbalancing or failover neccessary. Enabling squid3, how surprising, breaks all the rules and forces all traffic though the systems standard gateway. I have read through various posts and suggestions made there but no luck. Is there any chance to get my scenario working well with current pfsense?
    I'm kinda shocked that this issue persists for two years and still not fixed. Multi-homed setups are really not an exotic environment when pfsense is used.



  • The problem goes further than squid, actually any package from the box it self will use default gateway.

    I have seen a setup where you setup a dummy interface, some how, and uses it as default GW, then makes a floating rule that takes all traffic out of this and put it through a gw group..

    Have not got it to work my self, so if You get it to work i like to know how ;-)



  • That is why I posted here and not in proxy forum ;)
    In some cases setting this option might help. But only if you have a straight forward setup like LAN1->WAN-GW1 and LAN2->WAN-GW2 etc.
    The underlying problem seems to be that floating rules (currently) not work if I summarize the posts I have been reading.



  • I think that the "easy" thing to do (for the clever developers) is to make it possible to set a GW group as default GW or something like i suggested here https://forum.pfsense.org/index.php?topic=93075.msg519228#msg519228



  • This is already broken since Version 2.0.x so I not hope for an official fix anymore, rather a clever workaround.
    Well I uninstalled squid3 as no use for it if multi-wan not working  :'(



  • I want to ask the same to you.


  • Banned

    @Karakaraza:

    I want to ask the same to you.

    No, nothing changed in past 3 days. It still does not work…  ::)


Log in to reply