HP SFP+ - pfSense 2.2.2 is not identifying



  • Hello all!
    I'm converting two DL180 G6's to dedicated pfSense 2.2.2 boxes that will have 2 10G connections, 1 from our core router and 1 from a new 10G internet connection. These are connection through a pair of Arista 7150's before connecting into the pfSense boxes.

    The issue I'm having is that pfSense isn't seeing the two - dual HP 10G Adapters. One is a HP NC550SFP and the other a HP NC522SFP. I'm using HP P/N 455885-001 HP 10Gb SR SFP+ module's for the Fiber connections. I have Intel SFP+s available that I tried, but just not seeing anything. Does anyone have any recommendations for me? This is a vanilla install and I haven't touched a thing. I'm wondering if I need to do something special for these, just not sure.



  • first check the freebsd10.1 compatibility list to see if the cards are actually supported



  • Thank you! I forgot to check that, thank you for reminding me!

    The cards we are trying to use are not on that list. I'm think we may need to go virtual with this. I appreciat the help!



  • I dug into the possible driver issue further. These HP cards are actually Intel cards and should be covered under the ixgbe driver (in FreeBSD since 7.2). Searching the forum for similar issues, I do see a few people having some issues.

    Would installing the latest driver solve this issue: https://downloadcenter.intel.com/download/14688/Network-Adapter-Driver-for-PCI-E-10-Gigabit-Network-Connections-under-FreeBSD-

    I've never installed a driver in pfSense, so is it pretty straight forward if this is the path I need to go down?



  • you could try, but chances are some of the things required to "install" or compile the driver won't be included in pfSense (it's a stripped version of freebsd, with lots of crap left out).

    chances are, you would need to install freebsd 10.1 (in a virtual machine). then install the driver. then copy the needed files over to pfSense.

    https://forum.pfsense.org/index.php?topic=82115.msg453363#msg453363



  • I was reading through that earlier (while working in the data center) and am thinking of venturing down that route. I ran across loader.conf today and noticed that if_ixgbe_load is set to NO. I tried setting this to YES, in the /boot/defaults/loader.conf, but to no avail. It really seems like this driver is there… but just not loading properly.

    I'm downloading FreeBSD 10.1 now though.



  • five0va, did you manage to solve this issue or did you go the virtual route?



  • @five0va

    I was reading through that earlier (while working in the data center) and am thinking of venturing down that route.

    And there is no way to buy a supported SFP+ NIC? Nothing? But a 10 GBIt/s from the ISP is available?
    Hm, curios, if I can pay such an ISP up-link and have a need of this. I will be also having money to buy
    a sufficient NIC that is supported by pfSense.