Bridging HG8245H



  • Hello,

    My provider has a FTTH service utilising GPON, they have provided me with the Huawei HG8245H ONT. I requested a static IP and they have given me an address of 161.0.1xx.xxx, according to them this is what they call a Public LAN address, however it is accessible from outside, although in the ONT configuration you can see it has I believe a WAN IP address of 172.22.1xx.xxx. For example, I have an Asterisk PBX in my network and I'm able to reach it via the 161.0.1xx.xxx IP. The ONT comes with two options, Route WAN or Bridge WAN. Essentially, when I configured the ONT with the static address I was advised as I'm using it with another router other to disable NAT etc. pfSense does NAT, Firewall etc. What I'm trying to do, is do all the routing on my own equipment instead of using the HG8245H, my provider uses PPPoE for authentication, but from it seems, they do not provide any addressing through that like I'd assume most PPPoE connections do, so whenever I try to bridge the ONT I'm unable to communicate with it obviously pfSense doesn't get an address from the PPPoE session. How can I provide an address for PPPoE connection since I don't get one automatically?



  • A device that does bridge only mode should work for you, add your ISP username & password to ppoe, make sure your wan is using the ppoe entry, then add your assigned IP's to the virtual IP section of pfsense, as the bridged modem will still be assigned a "random" ip address to you by your ISP in most cases I have seen.

    More detailed how to's can be found with Googles help or paying for a bit of support might be expedient.



  • Hello,

    I'm still struggling with this issue but I've attached some photos to see if they can be of any help. Presently, I have a static IP as I've mentioned of 161.0.153.xxx, I've disabled NAT and DHCP on the HG8245H ONT and on the pfSense unit I'm using on the WAN interface the 161.0.153.xxx as the gateway and it works. I have another connection that's DSL and it works over PPPoE but it doesn't have a static IP assigned. The problem I'm having is I'm not sure how to assign my static IP to the PPPoE (Fibre) connection and if need to create the VLAN as well on the pfSense interface, or anything of that sort. I'm just trying to place my ONT in bridge wan mode and have it authenticate over PPPoE whilst getting the static address assigned to me.

    Thank you for any assistance.






  • I think you need to create a VLAN on your pfsense wan port with the same id (286 according to your screenshot) and then create the pppoe connectio over that tagged vlan.
    Also it could be normal the ONT not being accesible from the pfsense box, I got a HG8240H and from what I've read when the device is in bridge mode it's only accesible when there is no pppoe connection, when the pppoe is active the ont ip doesn't even respond to ping (unless of course I didn't set up the virtual ip for the wan correctly which could be very possible as I'm very new to pfsense…)



  • I have tried that, where it says WAN in pfsense on the dashboard it brings up a green arrow but without an IP address, so I'm guessing the PPPoE connection is happening then? What's the process to be able to assign my static to this connection now?



  • If you try bridging the ONT from the ISP it would not route the WAN, another device behind the ONT must then
    hold the static IP address (161.xx.xx) and do the entire routing. If your ISP is using the PPPoE you could try
    out the following;

    • Enter the PPPoE user name and passwort in the OTN
      and use the bridge mode
    • Enter the static IP address 161.xx.xx in the pfSense
      WAN set up and try it again.


  • Thanks for the replies everyone.

    Once the device is placed in it's bridge mode, there's no way to enter a username and password. It seems that the PPPoE session needs to be initiated by the pfSense then communicate it to the ONT.



  • @nicholas1520:

    Thanks for the replies everyone.

    Once the device is placed in it's bridge mode, there's no way to enter a username and password. It seems that the PPPoE session needs to be initiated by the pfSense then communicate it to the ONT.

    Oh ok this was not clear to me. Then you could perhaps ask at your ISP what is the best way to connect
    you custom firewall to their Network or plain the Internet. I am pretty sure they know a way to go for you.


Log in to reply