Can't uninstall snort??



  • Hello everyone, i'm running 1.2 stable. I installed snort and it didn't seem to be working at all, so i attempted to remove it through the webui, that didn't work. I tried to re-install it through the webui, no go. No matter what i do i get this error:

    Warning: delete_package(/usr/local/pkg/snort.inc): failed to open stream: No such file or directory in /etc/inc/pkg-utils.inc on line 733 Fatal error: delete_package(): Failed opening required '/usr/local/pkg/snort.inc' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg') in /etc/inc/pkg-utils.inc on line 733

    I have also tried to delete it manually with pkg_delete -f snort and all i get in return is no such package. It seems to be gone, however the web interface is unaware of this? Does anyone know how i can completely purge it from the system so it can be reinstalled and hopefully work short of a system format? Thanks!



  • Download the config.xml from diagnostics>backup/restore. Edit it with a unix aware texteditor like http://pspad.com. Strip out the snort package section and reupload it (pfSense will reboot). It should now be gone.



  • That did the trick, thanks a lot!



  • I still see this on:

    1.2-RELEASE
    built on Sun Feb 24 17:13:15 EST 2008



  • Then follow the instructions that hoba provided.



  • @submicron:

    Then follow the instructions that hoba provided.

    I had another issue that a fan was broken and the device wouldn't restart because of this failing fan after placing the changed XML back, I directly moved my other backup FW into the vlan and had everything working in seconds… the same day I fixed it as I did before by removing the part from the XML as mentioned :)

    Thanks !


Log in to reply