Boot issue with adaptec 2940au


  • This computer is a Dell Dimension XPS D233. Essentially it's an intel motherboard (i think) with a 440LX chipset. FreeBSD 4.10 and 6.0 work on it perfectly fine.

    The hard drive is an old quantum trailblazer (700 MB SCSI) connected to an adaptec 2940AU http://www.maxtor.com/portal/site/Maxtor/menuitem.5d2b41d3cef51dfe29dd10a191346068/?channelpath=/en_us/Support/Product%20Support/Desktop%20Storage/Quantum%C2%AE%20Drives/Trailblazer

    I've attempted to install pfSense beta 1 and beta 2 with and without "packet mode" but the same error occurs. Booting the hard drive in vmware works perfectly fine.

    The error:
    After the BIOS, the following text appears:

    Read Error

    Any ideas?

    Thanks,
    Jeff



  • If after installation, you get a cannot load kernel error

    Well, mine is "read error" which isn't the same I think, but there is no way to manually enter the hard drive geometry on the 2940au.

    If the installer fails to start correctly (system reboots), try (try each substep, then rerun the installer each time)

    The installer works perfectly fine. In fact as I mentioned above pfSense installs a bootable OS that works in vmware, it just wont work on the 2940au.

    If the LiveCD starts to boot but you start to get hundreds of errors, try:

    Nope, no errors when booting from the Live CD.

    If you are getting a read error during boot, please see this Boot Error∞.

    Ah yes, here we go.

    Unfortunately I already ahve been to the web page that this links to. I installed GAG and added FreeBSD to the boot menu, but upon selecting FreeBSD I once again recieve "Read Error".

    Lastly, what is CHS mode?


  • CHS mode is a BIOS setting.  You must be a young whipper-snapper if you don't remember CHS mode ;)


  • Oh yes I see what you mean. Well, this being SCSI and all, there seems to be no way to enter that in manually.


  • Ahh, then you are most likely running into http://www.freebsd.org/cgi/query-pr.cgi?pr=bin/90093 which I am affraid there is very little we can do.

    Try a different hard drive, etc is about all I can say at this point.


  • Yep, in fact I've already ordered a 7 GB IDE hard drive, so I will be ignoring SCSI all together.

    Still though I wonder, what version of pfSense might be based on a version of freebsd 6.0 or older? Because freebsd 6.0 works with the configurion I've been trying to use, so I figure an older version of pfSense might also?

    And thank you very much for trying to help!


  • 700meg trailblazer, I haven't seen one of those in years. The 2940 should work without any problems.


  • Just on a hunch, I'm downloading pfSense .86.4. I figure it's baased on an older version of FreeBSD that doesn't have this problem. If I still get the error, well I dunno.


  • .86.4 had the same problem. I also today got a Maxtor 30768H1, a 7 GB IDE hard drive.

    Installing pfsense beta 2 on this hard drive also resulted in a "read error", however I discovered a work-around.

    I installed the minimal version of FreeBSD 6.0. I used the FreeBSD isntalled to install the boot loader and partition the hard drive. Then I rebooted and started the pfSense installer. I skipped the formatting and bootloader steps. pfSense then went on to create its slices and copy its files as usual.

    Upon rebooting, the FreeBSD 6.0 boot loader booted into pfSense.

    My best guess is that there's something wrong with the pfSense installation procedure.  :-\

    Jeff


  • Again, please read: http://www.freebsd.org/cgi/query-pr.cgi?pr=bin/90093

    We do not use sysinstall so we are affected by this bug.


  • Anyway, at least this problem has a work-around.