DHCP doesn't assign IP address to opt1 interface



  • Hi all,

    I just installed pfSense the current version. except WAN and LAN interfaces, other things are running smooth.

    The OPT1 doesn't assign any ip address, even the LED light on that ethernet card is off all the times.

    When I try to setup Services:DHCP Server, the OPT1's subnet doesn't showing and the system log told me that

    php: : Could not find /tmp/xl0_router. Needed for dhcp gateway information

    May I know how to make OPT1 works? Many thanks!

    Aldo



  • Try a crossovercable. Sounds like the link is not even up.



  • Yea! crossover, almost forgot we do need this kind of cable sometimes. Thanks for the auto-cross function, I haven't use that for long!

    Thanks a lot for reminding!

    However, I've followed some steps from other website. configured OPT1 as static, given an IP address, e,g, 192.168.10.1/24
    enabled it in firewall:rules, source:192.168.20.1/24 leave other options all *

    then set the DHCP as following

    Hopfully, in Status:Interfaces, it's showing up but 'no carrier' and under Systme Logs

    php: : Hotplug event detected for xl1 but ignoring since interface is not set for DHCP

    Still can't retrive an IP via DHCP. Now opening up every boxes to find the crossover baby :)

    Aldo



  • Another doubt is that, the LAN interface is connected by straight cable between the pfSense box and another PC. They are still lan card to lan card connection but do not have that problem…



  • Some clients now have automdx on the nics. Actually all recent notebooks hat I have seen do it, some desktop pcs too.



  • Hi,

    I have been checked again. The LED of OPT1 is still off. My network is like the attached diagram.

    The LAN interface works fine but for OPT1, have been tried straight and cross over cables to connect with another NIC or router or switch. None of them seems can get a physical connection. All indicated 'media disconnected'.

    However, when I tried to connect my PC, which is running okay with LAN interface, to OPT1, that worked and only that worked. Sounds pretty strange!

    At least I know, both NICs are physically working and the cables I tested are okay. Is there anything I have to do in the pfSense box to make it work?

    Many many thanks!

    Aldo




  • I would change the opt1 nic. Something is fishy with it.



  • Thanks for your help hoba!

    Yes, I changed a intel NIC, as well as a new cable. Guess the problem was because of the physical problem!

    Aldo


Locked