Gigabyte Z97N-WIFI - Atheros NIC Drivers



  • I recently purchased this mainboard for our custom pfsense firewall, I understand that the Atheros NIC unsupported in 10.1R FreeBSD, However 10.1Stable seems to support the nic, Now i have tried a few of the methods i have found where i was supposed to be able to get the NIC driver module later versions of FreeBSD and have them work however this seem to not be the case for me.

    ive tried using the loader.conf.local method described here and in a few other places and it does not seem to detect the nic, Now im pretty sure that the H97N and the Z97N have the same NIC's… so i am at a loss atm. I have also tried manually loading the .ko module with kldload and it gives me a version mismatch (have tried FreeBSD 11.0, and 10.1S) and says the module is kernel dependent...

    Any ideas how i can get this going...

    Gygabyte Z97N-WIFI
    8GB Kingston DDR3 1600
    Intel Pentium G3250 3.2ghz DC
    120GB Kingston SSD

    Thanks,

    Tried:
    https://www.reddit.com/r/PFSENSE/comments/32pgw4/driver_issues_with_atheros_nic/

    and also checked other similar posts and most got it working..



  • 2.2.1 and newer have the Atheros wireless driver from FreeBSD 11-CURRENT, the newest available, which we've updated with each subsequent release. That 11ac card isn't yet supported in any FreeBSD version unfortunately.


  • Netgate Administrator

    I assume you're talking about the alc(4) Ethernet driver here?
    I'm pretty sure I saw that working in other threads. Did you use the correct 32/64bit version?

    Steve


  • Netgate Administrator

    You could try the alx driver compiled against FreeBSD 10 from here: https://forum.pfsense.org/index.php?topic=78932.msg434620#msg434620
    That code is now in alc though so the module from 10 stable should now have it.

    Steve



  • Im not to concerned about the WIFI adapter atm, Its the wired NIC that i cannot for the life of me get going… i downloaded freebsd 11, and 10.1S and for some reason its not detecting it... im going to try installing windows on the machine to make sure that its not a hardware defect as i have seen it working other threads as well..

    Ill keep you posted, and the modules that i pulled from the FreeBSD builds were from the x64 builds, Which is what i have installed on my pfsense box..

    Edit: I was speaking of the ALC(4) module.



  • Oh, I was assuming the wifi given wifi in the subject, but that's just part of the model number. The wired NIC should work with what stephenw10 mentioned, and should work with the most recent FreeBSD 11 snapshot. Trying Windows is a good idea to make sure it works.



  • What i will do is Install windows, Making sure both NIC's are visible and working, then i will do a full re-install of pfsense, I will try both 32 and 64 versions.. and the modules for them and report back.



  • Alright so after much testing… The if_alx.ko package worked!!!

    Thanks everyone for the help!

    The NIC model is AR8161 PCI-E!



  • For people who want to get their Atheros NIC to work on pfsense 2.2.4 (running FreeBSD 10.1) - here's the link: https://forum.pfsense.org/index.php?topic=78932.msg434620#msg434620
    arrmo uploaded a file if_alx.ko which works well!. You can dynamically kldload it to test and add it to loader.conf so its loaded on system startup.


Log in to reply