Reverse NAT problem



  • It appears I have a reverse NAT problem.

    I've been trying to troubleshoot various problems I have with the SQUID reverse proxy, and in the end, I was told the problem was really with reverse NAT.

    Check out this thread :
    https://forum.pfsense.org/index.php?topic=94409.15

    Any help would be greatly appreciated :)



  • Instead of starting a new thread I "hijack" this one.

    My problem must also be reverse dns …

    Here it goes (it's a webserver)...

    I have a domain at godaddy  mydomain.com

    On godaddy I have  mydomain.com -> my public static ip : port

    on Pfsene I have NAT for

    my public static ip : port -> my internal private ip

    From browser I type :  www.mydomain.com  and I reach my webserver but the url changes to :  my public static ip : port /bla../bla

    I want the visitor to get back the domain url : www.mydoamin.com/bla../bla

    Have done some search in the past but always end up on threads of resolving internal network and that kind of stuff. I don't know where to look. I don't even know if there is something I have do to on godaddy side.
    I have tried with 2 different webservers. Dokuwiki and owncloud. Both of them is virtual under proxmox. Is the proxmox host to blaime  ?

    But when the request reach proxomox it's using the internal private subnet.

    If someone just could point me in the right direction

    pfsene 2.2.2
    dns resolver (for internal)

    Thanks in advance ...

    (And sorry for using your thread but it sort of the same topic)...



  • @pernils:

    (And sorry for using your thread but it sort of the same topic)…

    No prob bro, just wish someone would help my desperate ass ;)


Log in to reply