Squid3 + Squidguard



  • Bom dia.
    Estou com um problema simplorio mas como estou bitolado de tanto ler log do squid ja estou louco e não consigo pensar numa solução.
    Bom vejamos.
    Cenário é este:
    ADSL -> PFSense >Squid/SquidGuard -> Usuarios.
    Bloqueio de facebook utilizando filtro ssl + certificado + squid guard, perfeito!(vide img)

    Porem eu tenho outro grupo cadastrado no squid guard onde eu libero todos os acessos.
    É o grupo da diretoria da empresa.
    Problema é liberar o facebook.
    Ele acessa o website porem de forma incorreta, não carrega alguns scritpts da pagina de modo que fica "bugado"(vide img).

    Por favor, vocês conhecem alguma solução pra resolver isso, ja até refiz o squid3 + squid guard.
    Nos logs do squid quando tento acessar facebook aparece "TAG_NONE/400 error:invalid-request".

    Obs: Não existe nenhuma regra para bloqueio de facebook via host apenas faço o bloqueio pelo squidguard.
    Obs2: Utilizo proxy transparente.



  • @netscaper:

    Bom dia.
    Estou com um problema simplorio mas como estou bitolado de tanto ler log do squid ja estou louco e não consigo pensar numa solução.
    Bom vejamos.
    Cenário é este:
    ADSL -> PFSense >Squid/SquidGuard -> Usuarios.
    Bloqueio de facebook utilizando filtro ssl + certificado + squid guard, perfeito!(vide img)

    Porem eu tenho outro grupo cadastrado no squid guard onde eu libero todos os acessos.
    É o grupo da diretoria da empresa.
    Problema é liberar o facebook.
    Ele acessa o website porem de forma incorreta, não carrega alguns scritpts da pagina de modo que fica "bugado"(vide img).

    Por favor, vocês conhecem alguma solução pra resolver isso, ja até refiz o squid3 + squid guard.
    Nos logs do squid quando tento acessar facebook aparece "TAG_NONE/400 error:invalid-request".

    Obs: Não existe nenhuma regra para bloqueio de facebook via host apenas faço o bloqueio pelo squidguard.
    Obs2: Utilizo proxy transparente.

    Netscaper já me deparei com isso!

    Mas no meu caso eram regras que estavam configuradas para bloqueio do IP do facebook.



  • Pois é, estou inicializando uma nova configuração para avaliar meus erros e minhas regras.
    Obs; Apesar de não ter nenhuma regra de bloqueio via firewall, estarei comentando aqui com os resultados.



  • Pode postar o .conf do SG e do squid?
    Já tentou fazer bloqueio pelo ASN utilizando Rules?

    ps: se possivel também o (cache.log, access.log) squid, (block.log e squidGuard.log) squidGuard



  • @shamuel_:

    Pode postar o .conf do SG e do squid?
    Já tentou fazer bloqueio pelo ASN utilizando Rules?

    ps: se possivel também o (cache.log, access.log) squid, (block.log e squidGuard.log) squidGuard

    Impossivel te fornecer esses arquivos formatei o pfs.
    Mas o problema nao é no squidguard!
    É no squid3(3.4.10_2-amd64).
    Mas as configurações estão padrão !

    Squid:

    Retorno site:



  • Hum… Você está fazendo bump pelo SSL e usando Transparent Mode.
    Este erro refere-se ao bump do SSL, remova a configuração feita no "cert adapt".
    Na criação do certificado você colocou o IP e hostname no certificado?

    O Facebook ira carregar normal, mas apreciei problemas que estou procurando soluções ainda, em outros sites conforme um post que fiz aqui no forum.

    Veja também a possibilidade de trabalharam em modo não transparente.

    Caso deseje apenas bloquear o Facebook, e não esteja fazendo gestão por LDAP no squid para grupos e sim por IPs, use a dica que lhe disse acerca de ASN



  • @shamuel_:

    Hum… Você está fazendo bump pelo SSL e usando Transparent Mode.
    Este erro refere-se ao bump do SSL, remova a configuração feita no "cert adapt".
    Na criação do certificado você colocou o IP e hostname no certificado?

    O Facebook ira carregar normal, mas apreciei problemas que estou procurando soluções ainda, em outros sites conforme um post que fiz aqui no forum.

    Veja também a possibilidade de trabalharam em modo não transparente.

    Caso deseje apenas bloquear o Facebook, e não esteja fazendo gestão por LDAP no squid para grupos e sim por IPs, use a dica que lhe disse acerca de ASN

    No certificado não informei ip nem hostname ! É uma CA normal criada no pfs.
    Tanto transparente quanto autenticado acontece o mesmo erro.
    Estou implementando apenas o pfs sem auxilio do AD.



  • "Este erro poderá ser corrigido desabilitando a opção de certificate adapt do squid"

    Chegou a testar?


Log in to reply