T-Mobile HotSpot Z915

  • Has anyone tried the USB NIC in the "T-Mobile HotSpot Z915"… I have one sitting in my desk at work for personal use and I was thinking about getting a little pfSense box to keep my VPN tunnels up.

  • Depends on what your hardware is. Most USB cell modems require extra fixup due to mass storage device needing ejecting.
    Here is the u3g device list for Freebsd 11

  • So it looks like it is an ZTE Z915. I don't see any ZTE modems on the list. I do see Linux support advertised.

  • I guess you could try to put it in tethering mode and attach via USB. Hook up to it via ue0 interface. Some people here are using the Verizon jetpack device tethered via USB..

  • I just added one of these hotspots onto my account for $10 a month. Plugged it into my pfSense box running 2.2.3 and it was recognized and working in minutes, couldn't be happier. Using it as a backup connection.

  • FWIW, I can confirm cwallace's experience. Plugged it in, and pfSense recognized it. I then setup the interfaces and such in pfSense and am now using it as a backup connection.

    Be advised that T-Mobile, like many other cellular providers, blocks inbound connections.

  • I am trying to add the ZTE Z915 as a backup connection, but I can't seem to configure it properly as an interface.  I'm using pfsense 2.1.5, and the internal LAN is

    After plugging it in, the ZTE is recognized as ue0, and I can ping the interface at (assigned by DHCP on the ZTE I presume).  I assume that is the gateway itself.

    For the gateway, I've tried both assigning both and, and I've also tried leaving it blank/dynamic (see image), all options do not seem to be passing traffic through.

    ![zte interface 1.JPG](/public/imported_attachments/1/zte interface 1.JPG)
    ![zte interface 1.JPG_thumb](/public/imported_attachments/1/zte interface 1.JPG_thumb)
    ![zte gw 1.JPG](/public/imported_attachments/1/zte gw 1.JPG)
    ![zte gw 1.JPG_thumb](/public/imported_attachments/1/zte gw 1.JPG_thumb)

Log in to reply