DL360/DL380 Gen9 Kernel Panic on Install



  • Anyone else tried installation on an HP DL360/DL380 Gen9?

    With x2APIC support enabled, PFsense BSD kernel panic's on installer bootup with the following error:

    Event time „LAPIC“ quality 600
    ACPI APIC Table: <hp   ="" proliant="">panic: APIC: CPU with APIC ID 0 is not enabled
    cpuid = 0

    Presumably a bug x2APIC and BSD, is there a known fix aside from disabling x2APIC?</hp >



  • Thread here seems to indicate it's a BIOS bug.
    https://lists.freebsd.org/pipermail/freebsd-stable/2015-February/081890.html

    got the latest BIOS on it?

    Can find similar references to Linux, but Linux seems to auto-disable x2APIC after detecting it as broken, so doesn't crash.



  • New as of May 15th, 2015, latest HP has available.  So the fix really is just to disable it altogether?

    Thanks Chris.



  • That's what it seems like from the Google results I was looking through. On similar if not identical HP servers you can find Linux boot log output that says something along the lines of x2APIC broken, disabling.

    Trying the most recent FreeBSD 11-CURRENT snapshot might be telling, in at least determining whether or not it's still a hardware issue, or if it's one that's been worked around in software.
    ftp://ftp.freebsd.org/pub/FreeBSD/snapshots/amd64/amd64/ISO-IMAGES/11.0/

    not that it'll help you at this instant, but it's at least another data point. Booting a Linux distro and looking for logs along those lines might also be telling.


Log in to reply