Pfsense i386 2.2 + Squid 3 + WPAD



  • Configurei o WPAD conforme esse tutorial, http://irj972.co.uk/articles/pfSense-WPAD-PAC-configuration
    E ainda não consigo fazer com que os navegadores adquiram automaticamente os dados para a conexão. Se eu adicionar o squid manualmente (adicionar o caminho do proxy no navegador) tudo funciona ok, mas se eu deixar o navegador no automático, não funciona, mesmo quando bloqueio a porta 80 no firewall (pq bloquear a porta 80? só bloquear vai jogar para a 3128?)
    Li diversos tutoriais, vi vários arquivos de configurações, todos meio que sao parecidos, tentei todos… não consegui. Alguém tem um passo a passo para eu checar? Alguém que tenha conseguido fazer?

    Meu pfsense está na maquina 10.1.2.254
    ela é o gateway principal, tento fazer com q o navegador tente configurar para 10.1.2.254:3128



  • Pode ser problema com DNS.
    Teste em um host: "ping wpad" e veja se o nome é resolvido, se não for não vai funcionar.



  • Nao consegui pingar, alguma sugestao? Eu configurei o DNS segundo esse tutorial



  • Provável que seja de sufixo de DNS.



  • Estou usando DNS Resolver, e as configurações do wpad estao no host overrides.



  • Então estou com o mesmo problema, porem o meu responde pra dentro da rede normalmente o wpad."dominio".
    Se eu for nas configs do proxy e setar o caminho do wpad pelo endereço http, funciona perfeito, maaaaaaaaas automatizado não funciona.



  • Tem que pingar sem colocar ."dominio". Veja se a interface recebeu a configuração de sufixo do dominio.



  • Eu estou com o mesmo problema. Uso o pfsense 2.2.1 + squid3+ squidguard, segui o mesmo tutorial, consigo pingar para o sevidor web, mais o script não funciona automaticamente. So funciona no IE quando eu seto manualmente. Alguém consegue usar o WPAD automaticamente no DHCP?



  • Consegui aqui graças a ajuda do Tomas. Configurei o WPAD no dominio, DHCP e DNS, agora se eu deixo para a maquina adquirir IP, funciona sem problemas. Alguem continua com problema? uma coisa que eu percebi é que o pfsense nao pode estar funcionando em HTTPS, quando eu deixo a interface web http. Funciona ok… a sim, nao pode usar a porta 80, já q o WPAD vai usar essa porta para servir o arquivo.



  • @m4kin:

    Consegui aqui graças a ajuda do Tomas. Configurei o WPAD no dominio, DHCP e DNS, agora se eu deixo para a maquina adquirir IP, funciona sem problemas. Alguem continua com problema? uma coisa que eu percebi é que o pfsense nao pode estar funcionando em HTTPS, quando eu deixo a interface web http. Funciona ok… a sim, nao pode usar a porta 80, já q o WPAD vai usar essa porta para servir o arquivo.

    Para isso é necessário ter um outro serviço rodando na porta 80. Aí pode deixar as interface de administração em HTTPS, se você tem um servidor web na rede pode deixar o wpad nele.


Log in to reply