Again IPv6 issue with final 2.2.3



  • As the subject says. After the update to final 2.2.3 I have again trouble with IPv6. Neither I nor my ISP did any changes in the configuration.


  • Banned

    I have a trouble with my car. It won't go.



  • Sorry. Same issue like here https://forum.pfsense.org/index.php?topic=90699.0
    Hoped that’s an known issue. That’s why I was that unspecific.  :-\



  • This was config error.
    Correct your ipv6 config and you'll be fine.
    You have a lot of examples in thread you posted…


  • LAYER 8 Global Moderator

    So dok can we get some more details about your car not going.. It is very difficult to help with such a lack of details ;) ROFL heheheheheh



  • Push it downhill and it will go :)


  • Banned

    @maverick_slo:

    Push it downhill and it will go :)



  • @maverick_slo:

    This was config error.
    Correct your ipv6 config and you'll be fine.
    You have a lot of examples in thread you posted…

    That’s my problem. I had no problem as I configured as described there. But have the same problem after the update to 2.2.3 final. Before I had 2.2.3 beta without issues. I don’t understand what has changed.


  • LAYER 8 Global Moderator

    So dok is your car red or some other color, red cars have more issues than other colors.. What brand of tires do you have - this info would be closer to fixing your problem than anything hidalgo has provided on his problem..


  • Banned

    Time for extreme measures:

    I'm your magic ball, click me! ↓↓↓



  • I clicked, doc has red car and this seems to be a problem.
    Hidalgo seriously, describe your problem, post some logs give us sth to work with.
    For starters, reboot pfsense and your isp router/modem and workstation and try again..



  • Ok. Try again. I had a working config as described here https://forum.pfsense.org/index.php?topic=90699.msg502932#msg502932
    After the update to version 2.3.3 final (from 2.3.3 dev) it doesn’t work anymore. That’s why I asked if something had changed without my knowledge.
    Now I tried this```
    [2.2.3-RELEASE][root@pfsense.quidproquo.ch]/root: /usr/local/sbin/dhcp6c -f -d -D -c /var/etc/dhcp6c_wan.conf -p /var/run/dhcp6c_vmx0.pid vmx0
    Jun/25/2015 20:37:52: extracted an existing DUID from /var/db/dhcp6c_duid: 00:01:00:01:1c:1c:69:1e:00:0c:29:b7:ef:4b
    Jun/25/2015 20:37:52: failed to open /usr/local/etc/dhcp6cctlkey: No such file or directory
    Jun/25/2015 20:37:52: failed initialize control message authentication
    Jun/25/2015 20:37:52: skip opening control port
    Jun/25/2015 20:37:52: <3>[interface] (9)
    Jun/25/2015 20:37:52: <5>[vmx0] (4)
    Jun/25/2015 20:37:52: <3>begin of closure [{] (1)
    Jun/25/2015 20:37:52: <3>[send] (4)
    Jun/25/2015 20:37:52: <3>[ia-na] (5)
    Jun/25/2015 20:37:52: <3>[0] (1)
    Jun/25/2015 20:37:52: <3>end of sentence [;] (1)
    Jun/25/2015 20:37:52: <3>comment [# request stateful address] (26)
    Jun/25/2015 20:37:52: <3>[request] (7)
    Jun/25/2015 20:37:52: <3>[domain-name-servers] (19)
    Jun/25/2015 20:37:52: <3>end of sentence [;] (1)
    Jun/25/2015 20:37:52: <3>[request] (7)
    Jun/25/2015 20:37:52: <3>[domain-name] (11)
    Jun/25/2015 20:37:52: <3>end of sentence [;] (1)
    Jun/25/2015 20:37:52: <3>[script] (6)
    Jun/25/2015 20:37:52: <3>["/var/etc/dhcp6c_wan_script.sh"] (31)
    Jun/25/2015 20:37:52: <3>end of sentence [;] (1)
    Jun/25/2015 20:37:52: <3>comment [# we'd like some nameservers please] (35)
    Jun/25/2015 20:37:52: <3>end of closure [}] (1)
    Jun/25/2015 20:37:52: <3>end of sentence [;] (1)
    Jun/25/2015 20:37:52: <3>[id-assoc] (8)
    Jun/25/2015 20:37:52: <13>[na] (2)
    Jun/25/2015 20:37:52: <13>[0] (1)
    Jun/25/2015 20:37:52: <13>begin of closure [{] (1)
    Jun/25/2015 20:37:52: <3>end of closure [}] (1)
    Jun/25/2015 20:37:52: <3>end of sentence [;] (1)
    Jun/25/2015 20:37:52: called
    Jun/25/2015 20:37:52: called
    Jun/25/2015 20:37:52: reset a timer on vmx0, state=INIT, timeo=0, retrans=383
    Jun/25/2015 20:37:52: a new XID (1ba820) is generated
    Jun/25/2015 20:37:52: set client ID (len 14)
    Jun/25/2015 20:37:52: set identity association
    Jun/25/2015 20:37:52: set elapsed time (len 2)
    Jun/25/2015 20:37:52: set option request (len 4)
    Jun/25/2015 20:37:52: send solicit to ff02::1:2%vmx0
    Jun/25/2015 20:37:52: reset a timer on vmx0, state=SOLICIT, timeo=0, retrans=1088
    Jun/25/2015 20:37:53: set client ID (len 14)
    Jun/25/2015 20:37:53: set identity association
    Jun/25/2015 20:37:53: set elapsed time (len 2)
    Jun/25/2015 20:37:53: set option request (len 4)
    Jun/25/2015 20:37:53: send solicit to ff02::1:2%vmx0
    Jun/25/2015 20:37:53: reset a timer on vmx0, state=SOLICIT, timeo=1, retrans=2151
    Jun/25/2015 20:37:55: set client ID (len 14)
    Jun/25/2015 20:37:55: set identity association
    Jun/25/2015 20:37:55: set elapsed time (len 2)
    Jun/25/2015 20:37:55: set option request (len 4)
    Jun/25/2015 20:37:55: send solicit to ff02::1:2%vmx0
    Jun/25/2015 20:37:55: reset a timer on vmx0, state=SOLICIT, timeo=2, retrans=4283
    Jun/25/2015 20:38:00: set client ID (len 14)
    Jun/25/2015 20:38:00: set identity association
    Jun/25/2015 20:38:00: set elapsed time (len 2)
    Jun/25/2015 20:38:00: set option request (len 4)
    Jun/25/2015 20:38:00: send solicit to ff02::1:2%vmx0
    Jun/25/2015 20:38:00: reset a timer on vmx0, state=SOLICIT, timeo=3, retrans=8905
    Jun/25/2015 20:38:09: set client ID (len 14)
    Jun/25/2015 20:38:09: set identity association
    Jun/25/2015 20:38:09: set elapsed time (len 2)
    Jun/25/2015 20:38:09: set option request (len 4)
    Jun/25/2015 20:38:09: send solicit to ff02::1:2%vmx0
    Jun/25/2015 20:38:09: reset a timer on vmx0, state=SOLICIT, timeo=4, retrans=17217

    
    Hope it helps. Still get an IPv6 address from my ISP but no IPv6 address to my client. Another log file```
    Jun 25 20:49:13	dhcpd: bootp in /etc/inetd.conf. Also make sure you
    Jun 25 20:49:13	dhcpd: are not running HP JetAdmin software, which
    Jun 25 20:49:13	dhcpd: includes a bootp server.
    Jun 25 20:49:13	dhcpd:
    Jun 25 20:49:13	dhcpd: If you did not get this software from ftp.isc.org, please
    Jun 25 20:49:13	dhcpd: get the latest from ftp.isc.org and install that before
    Jun 25 20:49:13	dhcpd: requesting help.
    Jun 25 20:49:13	dhcpd:
    Jun 25 20:49:13	dhcpd: If you did get this software from ftp.isc.org and have not
    Jun 25 20:49:13	dhcpd: yet read the README, please read it before requesting help.
    Jun 25 20:49:13	dhcpd: If you intend to request help from the dhcp-bugs at isc.org
    Jun 25 20:49:13	dhcpd: mailing list, please read the section on the README about
    Jun 25 20:49:13	dhcpd: submitting bug reports and requests for help.
    Jun 25 20:49:13	dhcpd:
    Jun 25 20:49:13	dhcpd: Please do not under any circumstances send requests for
    Jun 25 20:49:13	dhcpd: help directly to the authors of this software - please
    Jun 25 20:49:13	dhcpd: send them to the appropriate mailing list as described in
    Jun 25 20:49:13	dhcpd: the README file.
    Jun 25 20:49:13	dhcpd:
    Jun 25 20:49:13	dhcpd: exiting.
    Jun 25 20:49:14	dhcpd: Internet Systems Consortium DHCP Server 4.2.8
    Jun 25 20:49:14	dhcpd: Copyright 2004-2015 Internet Systems Consortium.
    Jun 25 20:49:14	dhcpd: Internet Systems Consortium DHCP Server 4.2.8
    Jun 25 20:49:14	dhcpd: All rights reserved.
    Jun 25 20:49:14	dhcpd: Copyright 2004-2015 Internet Systems Consortium.
    Jun 25 20:49:14	dhcpd: For info, please visit https://www.isc.org/software/dhcp/
    Jun 25 20:49:14	dhcpd: All rights reserved.
    Jun 25 20:49:14	dhcpd: For info, please visit https://www.isc.org/software/dhcp/
    Jun 25 20:49:14	dhcpd: Wrote 0 leases to leases file.
    Jun 25 20:49:14	dhcpd: Bound to *:547
    Jun 25 20:49:14	dhcpd: Listening on Socket/11/em0_vlan10/2a02:168:6002::/64
    Jun 25 20:49:14	dhcpd: Sending on Socket/11/em0_vlan10/2a02:168:6002::/64
    Jun 25 20:49:22	dhcp6c[83219]: exiting
    Jun 25 20:53:53	dhcpd: DHCPREQUEST for 10.0.1.13 from 00:26:55:58:8d:94 via em0_vlan10
    Jun 25 20:53:53	dhcpd: DHCPACK on 10.0.1.13 to 00:26:55:58:8d:94 via em0_vlan10
    Jun 25 20:59:11	dhcpd: DHCPREQUEST for 10.0.1.14 from 00:0e:08:d9:08:d8 via em0_vlan10
    Jun 25 20:59:11	dhcpd: DHCPACK on 10.0.1.14 to 00:0e:08:d9:08:d8 via em0_vlan10
    Jun 25 20:59:13	dhcpd: DHCPREQUEST for 10.0.1.252 from 30:46:9a:10:b1:04 via em0_vlan10
    Jun 25 20:59:13	dhcpd: DHCPACK on 10.0.1.252 to 30:46:9a:10:b1:04 via em0_vlan10
    Jun 25 20:59:27	dhcpd: DHCPREQUEST for 10.0.1.12 from 00:01:e3:76:66:b6 via em0_vlan10
    Jun 25 20:59:27	dhcpd: DHCPACK on 10.0.1.12 to 00:01:e3:76:66:b6 via em0_vlan10
    Jun 25 20:59:44	dhcpd: DHCPREQUEST for 10.0.1.202 from 24:a4:3c:10:1a:10 via em0_vlan10
    Jun 25 20:59:44	dhcpd: DHCPACK on 10.0.1.202 to 24:a4:3c:10:1a:10 via em0_vlan10
    Jun 25 20:59:44	dhcpd: DHCPREQUEST for 10.0.1.203 from 24:a4:3c:10:1a:2e via em0_vlan10
    Jun 25 20:59:44	dhcpd: DHCPACK on 10.0.1.203 to 24:a4:3c:10:1a:2e via em0_vlan10
    Jun 25 20:59:44	dhcpd: DHCPREQUEST for 10.0.1.201 from 24:a4:3c:10:1a:18 via em0_vlan10
    Jun 25 20:59:44	dhcpd: DHCPACK on 10.0.1.201 to 24:a4:3c:10:1a:18 via em0_vlan10
    Jun 25 21:00:03	dhcpd: DHCPREQUEST for 10.0.1.150 from 00:0b:82:28:57:85 via em0_vlan10
    Jun 25 21:00:03	dhcpd: DHCPACK on 10.0.1.150 to 00:0b:82:28:57:85 via em0_vlan10
    Jun 25 21:00:17	dhcpd: 3 bad udp checksums in 5 packets
    

    I really don’t know what happened



  • Try to do it like in this screenshot




  • Thank you all. I really don’t know what happened but after a third reboot and waiting for a while it’s working again. Without any changes. Very strange.  :D



  • YOu had to reboot your ISP equipment Im almost sure about that. If you use PPPoE sometimes when pppoe session is not disconnected properly it simply doesnt work until you reboot things :)

    Glad you made it working.


Log in to reply