How to automatically create IPv6 v6 gateway for GIF tunnel?

  • I am configuring another pfSense machine with tunnel brokered IPv6 connectivity. In the end an IPv6 gateway should automatically be created with the GIF.

    1. Create the Generic Interface (GIF):

    2. Create a new interface and attach it to the new GIF interface:

    3. Ensure the new WANv6 interface has both IPv4 and IPv6 set to None:

    4. Check that the _TUNNELV6 automatically created gateway is automatically created:

    except there is no _TUNNELV6 gateway. There is a _TUNNELV4 gateway; but that's a vestigal mistake that is planned to be fixed in a future release. The problem is that there is no V6 gateway.

    My home machine did correctly automatically create the  _TUNNELV6 gateway:

    And on my home machine i even then managed to edit it to the v6 gateway to be default for IPv6.

    But on this pfSense machine at work, pfSense refuses to automatically create the _TUNNELV6 gateway:

    I've done the steps, a few times. I've restarted the router. 2.2-RELEASE. What step am i missing to automatically create the automatically created gateway?

    Hero member CMB says:

    You don't manually add gateways for gif interfaces, the interface's _TUNNELV6 auto-added gateway is all you need.

    He also goes on to mention:

    How is Interfaces>WAN6 configured on your system? Should be "none" for both IPv4 and IPv6.

    That solved the issue for that person. Unfortunately, i already have my WANv6 interface configured for None/None.

    Another user was having the same issue, and hero member Cino mentioned:

    Go to Routing, Edit your HE gateway and then click Save. That should fix that.

    That solved the issue for that person.

    What am i doing wrong?

    Hero member doktornotor suggested i follow the instructions in the linked instructions i already linked to and followed. Obviously i already did; as demonstrated by the fact that when i properly follow the instructions i linked to and performed, it worked on another machine:

    What is going wrong here?

    Bonus Reading



  • Banned

    You need to edit the _V6 GW and set it as default. Save. Reboot. Done.

    (The useless _V4 thing is to be disabled for monitoring and ignored. There's a bug filed about it.)

  • @doktornotor:

    You need to edit the _V6 GW and set it as default.

    There is no _TUNNELV6 gateway. That is the issue i'm having.

    How do i convince pfSense to automatically create it?

  • Banned

    By following the linked howto properly. It works.

  • honestly the linked directions need updated they are a bit outdated and some screens don't match

  • Rebel Alliance Developer Netgate

    One thing you should double check is that you have followed the part in the directions labeled "Pitfalls" about making sure that System > Advanced, Networking tab has "Allow IPv6" checked. That's the only way I know of that will stop the v6 auto gateway from showing up.

    I plan on making some updates to the wiki doc after the hangout. I ran through the whole process a couple times this week and had no problems. The gateways showed up automatically as expected and everything worked. There were a few minor differences to the wiki doc but nothing earth shattering.

Log in to reply