Upgrade 2.2.2 > 2.2.3 OpenVPN re-install error (SOLVED)



  • First, thanks for releasing the updated version of pfsense!  I needed the fix to stop the error of more than 64 VIP address on my outside interface on our new production firewalls.  The good news is the error is gone.

    I'm getting a package error when trying to re-install openvpn both during the upgrade and while running a re-install after the upgrade to 2.2.3.    Here is the error:

    Downloading https://files.pfsense.org/packages/10/All/zip-3.0_1-amd64.pbi …  could not download from there or https://files.pfsense.org/packages/10/All//zip-3.0_1-amd64.pbi.
    of zip-3.0_1-amd64.pbi p7zip-9.20.1_2-amd64 failed!

    Here is the full log from the re-install attempt:
    Removing OpenVPN Client Export Utility components...
    Tabs items... done.
    Loading package instructions...
    Deinstall commands... done.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    Beginning package installation for OpenVPN Client Export Utility .
    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading OpenVPN Client Export Utility and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/10/All/zip-3.0_1-amd64.pbi ...  could not download from there or https://files.pfsense.org/packages/10/All//zip-3.0_1-amd64.pbi.
    of zip-3.0_1-amd64.pbi p7zip-9.20.1_2-amd64 failed!

    Installation aborted.Removing package...
    Starting package deletion for zip-3.0_1-amd64...done.
    Starting package deletion for p7zip-9.20.1_2-amd64...done.
    Removing OpenVPN Client Export Utility components...
    Tabs items... done.
    Loading package instructions...
    Include file openvpn-client-export.inc could not be found for inclusion.
    Deinstall commands...
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    done.
    Failed to install package.

    Package reinstallation failed.

    Thanks!


  • LAYER 8 Global Moderator

    Well clicking on your links starts a download.. So maybe you have an issue with resolving files.pfsense.org ?

    I just updated from 2.2.2 to 2.2.3 64 bit and had not problems with that package reinstalling. None of the packages had issues ladvd, openvpn, open-vm tools and vnstat2 all downloaded and installed fine.



  • Thanks for the response!

    The first few times, other packages such as snort were downloading ok, but not the OpenVPN Client export utility.  Now it just installed correctly on both of my machines.  Maybe it just took a while to sync a mirror?  Either way, all is well now.  This is resolved.

    Sincerely,

    kkm


Log in to reply