Cannot upgrade, image is corrupt?



  • A new version is now available

    Current version: 2.2.2-RELEASE
      NanoBSD Size : 1g
          Built On: Mon Apr 13 20:10:33 CDT 2015
        New version: 2.2.3-RELEASE

    Update source: https://updates.pfsense.org/_updaters

    Try to invoke auto-upgrade, and it downloads, then borks with:
    The image file is corrupt. Update cannot continue.

    Oh dear, looks like the poor little ALIX box may be running out of storage?
    Jun 25 08:49:58 php-fpm[89638]: /system_firmware_auto.php: The command '/usr/bin/gzip -t '/root/latest.tgz'' returned exit code '1', the output was 'gzip: /root/latest.tgz: not in gzip format'
    Jun 25 08:49:56 kernel: pid 89638 (php-fpm), uid 0 inumber 50962 on /: filesystem full
    Jun 25 08:49:55 kernel: pid 89638 (php-fpm), uid 0 inumber 50962 on /: filesystem full

    Any ideas how to free up space?


  • Banned

    Well, tried a reboot? before upgrade? What packages you have installed?


  • Rebel Alliance Developer Netgate

    That's what it's saying: It's out of space.

    1gb doesn't give much breathing room these days (actual OS slice would be ~500MB). If you have any packages installed, remove them before attempting the upgrade, that may help.

    Really though, finding a time to swap that out with a 4GB or larger card would be best at this point.



  • Well, rebooting may not have been the best thing… heh. Web GUI's down now it seems after rebooting. This... is going to be fun.

    @doktornotor:

    Well, tried a reboot? before upgrade? What packages you have installed?


  • Banned

    Get a bigger card, really. Failing that, avoid installing any packages whatsoever.


Log in to reply