Upgrade 2.2.2 to 2.2.3, Stuck Installing Packages



  • Hi,

    I just upgraded from v2.2.2 to v2.2.3, but my box seems to be stuck installing packages (for 2 hours now, not real it seems).

    I have tried a reboot, same thing.

    Any thoughts?

    Thanks!



  • @arrmo:

    Any thoughts?

    Yep.
    One : is it possible to have more info ?

    I upgraded, version 2.2.3 re-installed 'my' package (nut and system patches) on all was well.

    So, what up ? Your internet connection is broke ?
    What if you remove all package info from the config file - and import that modified file - afterwards, reinstall each package one by one to see "who blows up when".


  • Banned

    Instead of messing with config imports: IIRC there some Unlock button in Diagnostics - Backup/Restore to nuke the lock and reinstall the packages? Other than that, virtually no info here to debug anything.



  • Got the same problem…..after 30 min I force reboot and then the system was ok. I have few packages installed (Snort, pfBlockerNG-dev) and they are working.

    I strongly recommend, before any major update, to save your config.



  • Thanks for the pointers!

    Took 4 reboots, but after that - it was up and running … :).



  • for me i use cron, squid and squidguard and first one installs fine then next 2 stuck on extracting.

    after many reboots squid also installed but squidguard causes the machine to be inaccessible from remote location

    fatal error: call to undefined function sg_init() in /use/local/pkg/squidguard…...



  • to me it looks like when the tar program is running which extract the package installer, it messes up something or gets stuck on it forever thats y the reinstall issues happen.

    on alix nanobsd not much of a problem unless u use packages, the base pfsense 2.2.3 upgrade has no issues, all my machines upgraded and came online just fine but the package installation is the issue, i even tried unlocking the reinstalls and then doing it one at a time but all still get stuck on extracting forever, sometimes some manage to go past it after like 10mins and if they do then they work fine



  • I'm having the issue with it stuck on packages. I was walking a friend through installing pfsense and packages, it was getting stuck on extracting no matter what. I thought he was doing something wrong so I installed it at my location and have run into the exact same issue. Both using USB drives. He installed it to a HDD and it fixed the issue. Anyone know what could be causing it? Its only on USB drives that the issue shows itself. Could anyone test?


  • Banned

    Waste of time. Use the latest 2.2.4 snapshots; sync mounts with slow drives -> disaster.