Probleme mit hohen ports



  • Hi ich habe nu so viele embedded sys durch
    und wollte eigend lich bei pf bleiben ….
    nur hier habe ich das selbe prob das wen ich
    die flatcastports 40121 - 40124 (UDP)  durchrouten will
    das es irgendwie scheiters .....
    weiss einer von euch evtl eine loesung ????



  • Also entweder machst Du was falsch oder die Software ist besch…euert  ;D
    Was funktioniert nicht und wie hast Du das eingerichtet. Paste mal bitte Deine Portforwards und Firewallrules. Siehst Du den betreffenden Verkehr geblockt unter status>systemlogs, firewall? Beachte bitte auch daß die Reihenfolge der Regeln wichtig ist.



  • so steht das in meiner xml dadei drinne

    <rule><protocol>udp</protocol>
                <external-port>40120-40130</external-port>
                <target>192.168.0.205</target>
                <local-port>40120</local-port>
                <interface>wan</interface>
                <descr>Flatcast</descr></rule>

    <rule><type>pass</type>
                <interface>wan</interface>
                <protocol>tcp/udp</protocol>
                <source>
                    <any><destination><any><port>40120-40130</port></any></destination>
                <descr>NAT Flatcast</descr></any></rule>

    und in der NAT

    WAN  UDP  40120 - 40130  192.168.0.205  40120 - 40130  Flatcast

    und unter rules

    CP/UDP  *  *  *  40120 - 40130  NAT Flatcast

    eigend lich sollte das doch richtig sein

    oder teusche ich mich jetzt da ??

    Gruss Thomas



  • bevor ich das vergesse aleanderen post
    vnc , esel shoutcast ftp ssh etc laufen ja alle und das wundert mich ja so sehr das
    eben halt diese ports nicht gehen



  • Klingt für mich richtig. Der PC selbst hat keine Desktopfirewall? Siehst Du Blocks in den pfSense-Firewall-logs? Schau auch mal unter diagnostics>states, ob für die Verbindung states generiert werden. Wenn das passiert, dann ist Dein Problem nicht durch pfSense verursacht.



  • ich habe da was unter status.php gefunden was mich nu ganz zu grübeln bringt

    NAT Inbound Redirects

    rdr on ng0 proto udp from any to 85.176.119.162 port 40120:40130 -> 192.168.0.204 port 40120:*

    Reflection redirects

    rdr on sis0 proto udp from any to 85.176.119.162 port { 40120 } -> 127.0.0.1 port 19000
    rdr on sis0 proto udp from any to 85.176.119.162 port { 40121 } -> 127.0.0.1 port 19001
    rdr on sis0 proto udp from any to 85.176.119.162 port { 40122 } -> 127.0.0.1 port 19002
    rdr on sis0 proto udp from any to 85.176.119.162 port { 40123 } -> 127.0.0.1 port 19003
    rdr on sis0 proto udp from any to 85.176.119.162 port { 40124 } -> 127.0.0.1 port 19004
    rdr on sis0 proto udp from any to 85.176.119.162 port { 40125 } -> 127.0.0.1 port 19005
    rdr on sis0 proto udp from any to 85.176.119.162 port { 40126 } -> 127.0.0.1 port 19006
    rdr on sis0 proto udp from any to 85.176.119.162 port { 40127 } -> 127.0.0.1 port 19007
    rdr on sis0 proto udp from any to 85.176.119.162 port { 40128 } -> 127.0.0.1 port 19008
    rdr on sis0 proto udp from any to 85.176.119.162 port { 40129 } -> 127.0.0.1 port 19009
    rdr on sis0 proto udp from any to 85.176.119.162 port { 40130 } -> 127.0.0.1 port 19010
    rdr on ath0 proto udp from any to 85.176.119.162 port { 40120 } -> 127.0.0.1 port 19011
    rdr on ath0 proto udp from any to 85.176.119.162 port { 40121 } -> 127.0.0.1 port 19012
    rdr on ath0 proto udp from any to 85.176.119.162 port { 40122 } -> 127.0.0.1 port 19013
    rdr on ath0 proto udp from any to 85.176.119.162 port { 40123 } -> 127.0.0.1 port 19014
    rdr on ath0 proto udp from any to 85.176.119.162 port { 40124 } -> 127.0.0.1 port 19015
    rdr on ath0 proto udp from any to 85.176.119.162 port { 40125 } -> 127.0.0.1 port 19016
    rdr on ath0 proto udp from any to 85.176.119.162 port { 40126 } -> 127.0.0.1 port 19017
    rdr on ath0 proto udp from any to 85.176.119.162 port { 40127 } -> 127.0.0.1 port 19018
    rdr on ath0 proto udp from any to 85.176.119.162 port { 40128 } -> 127.0.0.1 port 19019
    rdr on ath0 proto udp from any to 85.176.119.162 port { 40129 } -> 127.0.0.1 port 19020
    rdr on ath0 proto udp from any to 85.176.119.162 port { 40130 } -> 127.0.0.1 port 19021

    self udp 80.132.212.209:40123 <- 192.168.0.202:40123      MULTIPLE:MULTIPLE
    self udp 212.202.148.210:40128 <- 192.168.0.202:40123      MULTIPLE:MULTIPLE
    self udp 192.168.0.202:40123 -> 85.176.119.162:60284 -> 80.132.212.209:40123      MULTIPLE:MULTIPLE
    self udp 192.168.0.202:40123 -> 85.176.119.162:56447 -> 212.202.148.210:40128      MULTIPLE:MULTIPLE

    @24 rdr on ath0 inet proto udp from any to 85.176.119.162 port = 40128 -> 127.0.0.1 port 19019
      [ Evaluations: 0        Packets: 0        Bytes: 0          States: 0    ]
    @25 rdr on ath0 inet proto udp from any to 85.176.119.162 port = 40129 -> 127.0.0.1 port 19020
      [ Evaluations: 0        Packets: 0        Bytes: 0          States: 0    ]
    @26 rdr on ath0 inet proto udp from any to 85.176.119.162 port = 40130 -> 127.0.0.1 port 19021
      [ Evaluations: 0        Packets: 0        Bytes: 0          States: 0    ]

    also irgendwie bring mich das doch zum grübeln ich habe auf den rechnern KEINE interne FW am rennen das macht alles die PF für mich

    benutzen tuhe ich die 1.0 BETA2 embedded

    gruss thomas



  • Pobier mal "Disable NAT reflection" unter system>advanced (ganz unten).


Locked