PPPoE over VLAN



  • Hi,

    I have got some pfSense knowledge but for some reason I cannot get this to work; My ISP told me to configure VLAN 6 on the WAN-interface of my pfSense and to configure PPPoE on the interface to get the public IP and setup a internet connection. But all I get is a red cross on the WAN interface when I do so. I have no idea where the problem lies. Anyone that can help me out with this ?

    Lots of thanks in advance!

    Regards,
    Bram



  • Anyone ?



  • Only to say that I am very surprised that an ISP would provide their service on a particular VLAN with it tagged to the customer. Because that means their customers have to have VLAN-capable devices at the ISP interface point.
    I suspect that is some verbal communication mismatch between the words the ISP is using and VLAN as we know and love it.



  • That's not all that uncommon of a setup. I'm guessing your CPE isn't configured appropriately for that purpose, or maybe there are multiple ports on the CPE and you're plugging into the wrong one. Does it connect without the VLAN tag?



  • Well it does but after trying some settings and rebooting a few times the interface now says connected instead of only displaying a red cross. However it still doesn't receive a public IP-adress. It's pfSense version 2.1.4 if that's any help ?





  • Hi neo243,

    wow that is exactly what fixed it! I constantly had to chose between VLAN6 or PPPoE on my interface but this has enabled me to do both! Thanks everyone for all your efforts!

    Grt
    Bram