Upgrade from 2.2.2 to 2.2.3 - now You don't have permission to access / on this server.



  • Everything was going well.
    So I upgraded to V2.2.3

    now I cannot access the web interface at all.

    I get the error 'You don't have permission to access / on this server.'

    The PFSENSE is running though.

    Does anyone know anything useful about this error or how to fix it?

    many thanks



  • Are you using https?
    Or are you being redirected to https?

    Try accessing your pfSense admin page like this:-

    http://192.168.1.1:80

    My guess is that you may have a new self-signed certificate to permanently accept.



  • I had something similar happen when my box assigned a bad IP to the bridged LAN port but still had rules operating that referenced the correct addresses for nat.

    try connecting a console cable to check that your LAN IP is right.

    after I upgraded, on boot it was assigning a VIP instead of the IP I'd configured.  wired clients with static IPS got routed to the login page but no login was permitted.



  • I did not have https switched on before. Anyway tried that and http - still no go.

    I checked the LAN static IP and its correct 192.168.1.1 (igb0) in my network and the external address is correct. The externall (em0) is DHCPed from my ISP and seems ok.

    So I don't think thats where the problem lies either

    Somehow the root web page is missing - this is more likely.



  • Did you try to restart the web configurator from the console?



  • As my setup is pretty simple - I am going to reload everything from scratch.

    nothing fixes it - although the Pfsense machine is still working. I do have access to the CLI.

    Restart the web configurator did not do anything useful



  • You're redirecting it somewhere else. There are suggested workarounds to get in here: https://doc.pfsense.org/index.php/Locked_out_of_the_WebGUI


Log in to reply