PPPoE issue after upgrading to 2.2.3



  • Hi all,

    After upgrading from 2.2.2 to 2.2.3 i got some pppoe issues.It looses ip and reconnects every 2-5 minutes.
    Jun 29 10:51:48 apinger: Could not bind socket on address(86.121.187.68) for monitoring address 213.154.124.1(WAN_PPPOE) with error Can't assign requested address
    Jun 29 10:51:48 apinger: SIGHUP received, reloading configuration.
    Jun 29 10:51:48 apinger: alarm canceled (config reload): WAN_PPPOE(213.154.124.1) *** down ***
    Jun 29 10:51:48 apinger: No usable targets found, exiting
    Jun 29 10:52:01 apinger: Starting Alarm Pinger, apinger(7519)
    Jun 29 10:52:04 apinger: Could not bind socket on address(86.121.132.149) for monitoring address 213.154.124.1(WAN_PPPOE) with error Can't assign requested address
    Jun 29 10:52:05 apinger: Could not bind socket on address(86.121.132.149) for monitoring address 213.154.124.1(WAN_PPPOE) with error Can't assign requested address
    Jun 29 10:52:06 apinger: Could not bind socket on address(86.121.132.149) for monitoring address 213.154.124.1(WAN_PPPOE) with error Can't assign requested address
    Jun 29 10:52:07 apinger: Could not bind socket on address(86.121.132.149) for monitoring address 213.154.124.1(WAN_PPPOE) with error Can't assign requested address
    Jun 29 10:52:08 apinger: Could not bind socket on address(86.121.132.149) for monitoring address 213.154.124.1(WAN_PPPOE) with error Can't assign requested address
    Jun 29 10:52:09 apinger: Could not bind socket on address(86.121.132.149) for monitoring address 213.154.124.1(WAN_PPPOE) with error Can't assign requested address
    Jun 29 10:52:11 apinger: ALARM: WAN_PPPOE(213.154.124.1) *** down ***
    Jun 29 10:52:12 apinger: alarm canceled: WAN_PPPOE(213.154.124.1) *** down ***
    Jun 29 10:52:19 apinger: SIGHUP received, reloading configuration.
    Jun 29 10:52:28 apinger: SIGHUP received, reloading configuration.
    Jun 29 10:52:37 apinger: SIGHUP received, reloading configuration.
    Jun 29 10:53:01 apinger: Error while feeding rrdtool: Broken pipe
    Jun 29 10:53:12 apinger: ALARM: WAN_PPPOE(213.154.124.1) *** down ***
    Jun 29 10:54:01 apinger: rrdtool respawning too fast, waiting 300s.
    Jun 29 10:54:03 apinger: SIGHUP received, reloading configuration.
    Jun 29 10:54:11 apinger: SIGHUP received, reloading configuration.
    Jun 29 10:58:01 apinger: Error while feeding rrdtool: Broken pipe

    –-------------

    Jun 29 11:14:38 ppp: [wan_link0] Link: reconnection attempt 30
    Jun 29 11:14:38 ppp: [wan_link0] PPPoE: Connecting to ''
    Jun 29 11:14:47 ppp: [wan_link0] PPPoE connection timeout after 9 seconds
    Jun 29 11:14:47 ppp: [wan_link0] Link: DOWN event
    Jun 29 11:14:47 ppp: [wan_link0] LCP: Down event
    Jun 29 11:14:47 ppp: [wan_link0] Link: reconnection attempt 31 in 1 seconds
    Jun 29 11:14:48 ppp: [wan_link0] Link: reconnection attempt 31
    Jun 29 11:14:48 ppp: [wan_link0] PPPoE: Connecting to ''
    Jun 29 11:14:57 ppp: [wan_link0] PPPoE connection timeout after 9 seconds
    Jun 29 11:14:57 ppp: [wan_link0] Link: DOWN event
    Jun 29 11:14:57 ppp: [wan_link0] LCP: Down event
    Jun 29 11:14:57 ppp: [wan_link0] Link: reconnection attempt 32 in 4 seconds
    Jun 29 11:15:01 ppp: [wan_link0] Link: reconnection attempt 32
    Jun 29 11:15:01 ppp: [wan_link0] PPPoE: Connecting to ''
    Jun 29 11:15:10 ppp: [wan_link0] PPPoE connection timeout after 9 seconds
    Jun 29 11:15:10 ppp: [wan_link0] Link: DOWN event
    Jun 29 11:15:10 ppp: [wan_link0] LCP: Down event
    Jun 29 11:15:10 ppp: [wan_link0] Link: reconnection attempt 33 in 3 seconds
    Jun 29 11:15:13 ppp: [wan_link0] Link: reconnection attempt 33
    Jun 29 11:15:13 ppp: [wan_link0] PPPoE: Connecting to ''
    Jun 29 11:15:22 ppp: [wan_link0] PPPoE connection timeout after 9 seconds
    Jun 29 11:15:22 ppp: [wan_link0] Link: DOWN event
    Jun 29 11:15:22 ppp: [wan_link0] LCP: Down event

    any clue on this ? did anyome had this issue on 2.2.3


  • Galactic Empire

    Let's try this. Go to System > Gateways and open your default gateway. From there check "Disable Gateway Monitoring". See if it happens again.

    Cheers.



  • @ivor:

    Let's try this. Go to System > Gateways and open your default gateway. From there check "Disable Gateway Monitoring". See if it happens again.

    Cheers.

    will try like this too…in any case as gateway I was using the dns server ip.and it worked fine for 1 year.


  • Galactic Empire

    @nikkon:

    @ivor:

    Let's try this. Go to System > Gateways and open your default gateway. From there check "Disable Gateway Monitoring". See if it happens again.

    Cheers.

    will try like this too…in any case as gateway I was using the dns server ip.and it worked fine for 1 year.

    Yup, I assumed it's your ISP DNS, which actually might be the reason for you issues. Some ISP DNS servers can get overloaded with pings and even drop your IP. I had this happen few years ago… doesn't happen often, but can.



  • it may be…now seems to work fine.
    we'll see. thx for helping


  • Galactic Empire

    If it works fine that was the issue then, your DNS doesn't like the pings! You can lower the number of pings or just use a different server to ping.


Log in to reply