Upgrade 2.2.2 –> 2.2.3: Listen queue overflow --> Bad performance



  • I just upgraded my AMD64 2.2.2 pfSense to 2.2.3 and now I get many, many errors due to listen queue overflow. Network performance has decreased dramatically.
    Before i had 600mbit throughput, now it's just about 40mbit.

    
    Jun 30 11:31:49 	kernel: sonewconn: pcb 0xfffff800853dc620: Listen queue overflow: 193 already in queue awaiting acceptance (5029 occurrences)
    Jun 30 11:30:49 	kernel: sonewconn: pcb 0xfffff800853dc620: Listen queue overflow: 193 already in queue awaiting acceptance (1481 occurrences)
    Jun 30 11:29:42 	kernel: sonewconn: pcb 0xfffff800853dc620: Listen queue overflow: 193 already in queue awaiting acceptance (3586 occurrences)
    Jun 30 11:28:41 	kernel: sonewconn: pcb 0xfffff800853dc620: Listen queue overflow: 193 already in queue awaiting acceptance (4230 occurrences)
    Jun 30 11:27:41 	kernel: sonewconn: pcb 0xfffff800853dc620: Listen queue overflow: 193 already in queue awaiting acceptance (71 occurrences)
    Jun 30 11:23:23 	kernel: sonewconn: pcb 0xfffff800853dc620: Listen queue overflow: 193 already in queue awaiting acceptance (2147 occurrences)
    Jun 30 11:19:02 	kernel: sonewconn: pcb 0xfffff800853dc620: Listen queue overflow: 193 already in queue awaiting acceptance (255 occurrences)
    Jun 30 11:18:02 	kernel: sonewconn: pcb 0xfffff800853dc620: Listen queue overflow: 193 already in queue awaiting acceptance (1 occurrences)
    
    Current listen queue sizes (qlen/incqlen/maxqlen)
    Tcpcb            Proto Listen         Local Address
    fffff80085e01400 tcp4  193/0/128      127.0.0.1.3128
    
    

    I read that increasing "kern.ipc.somaxconn=512" could solve this issue. I included it in /boot/loader.conf and /etc/sysctl.conf, but it has no effect on booting. I have to set it manually in cli "sysctl kern.ipc.somaxconn=512" and restart squid. Then listen queue is increased, but starts to fill up pretty fast.

    Question 1:
    -> How can I make kern.ipc.somaxconn persistant during reboots?
    Update:
    I added it to Advanced->System Tuneables. Now it's persistent between reboots.
    Question 2:
    -> Will there be a bugfix?

    I have a CARP cluster and ATM I set primary node to persistant maintenance mode, so that traffic is handled on the secondary, less performant backup system which is also AMD64 2.2.3 and does not have these issues. Is it driver related?



  • [Solved] –> See: https://forum.pfsense.org/index.php?topic=95837.0

    Had to remove the sync-option from /etc/fstab