Gre Tunnels does not get started on reboot



  • Hi,

    also with 2.2.3 configured gre tunnels does not get startet on reboot.
    described here: https://forum.pfsense.org/index.php?topic=58386.msg334399#msg334399
    This is a freebsd bug as described here: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=164475

    Does this fix also get merged to 2.2.4 or will this be later?

    best regards
    Thomas



  • +1 - I'm having the same issue on 2.2.3 and came across the same other posts stegbth mentions.  Using Shellcmd to bring the gre interface up at boot time does work for a straight GRE tunnel, however I'm also running GRE over IPsec.  When I use Shellcmd to bring up the GRE interface the IPsec tunnel comes up fine but simply won't pass any traffic until I remove the Shellcmd option and reboot pfSense.

    If I manually run 'ifconfig gre0 up' from SSH after a reboot the tunnel comes up fine.  It's almost like shellcmd is executing a little too early and I tried to run both as a shellcmd and earlyshellcmd.  The shellcmd type produced the behavior I described earlier, and earlyshellcmd type produces a result similar to nothing at all (gre tunnel not in running state).

    Is there a workaround to execute commands say 30 seconds after a full system startup that I'm otherwise missing?



  • Hi,

    i am also running GRE over IPsec, but currently did not made any further test.
    There is no bug listed in https://redmine.pfsense.org/projects/pfsense/roadmap
    So i don't know if the FreeBSD fix would move to 2.2.4?
    maybe the following shellcmd would work:
    sleep 30; ifconfig gre0 up

    On the other hand i run this tunnel in an failover mode, so there should be an possibility to combine this with CARP?

    best regards
    Thomas



  • Hi,

    same problem with 2.2.4 :(
    are there any plans to import the freebsd bugfix?

    best regards
    Thomas


  • Rebel Alliance Developer Netgate

    Try a 2.2.5 snapshot if you like, though IIRC that fix was only in FreeBSD 10.2 so you may have to wait for pfSense 2.3.

    You can make a shellcmd tag to "ifconfig gre0 up" (using the full path to ifconfig) which can help work around it.



  • If you have the GRE interface assigned and enabled, it should "just work" in 2.2.4 and 2.2.5 (and at least some prior versions to that). Any edge cases should be fine with the shellcmd 'ifconfig gre0 up'. The root issue is confirmed fixed in the base FreeBSD version in 2.3, so it works in all circumstances with no workarounds or edge cases or anything.


Log in to reply