2 Switches in a row Speedtests are slower and Internet feels clumsy



  • Hi Guys,

    i have a curious problem when i connect 2 Switches in a row speedtests are slower than normal instead of 110mbit/s 50mbit/s 6ms Latency | i have 35mbit/s 50mbit/s 15ms and the internet feels generally slower,
    but when i start downloads etc. i get the full 110mbit/s.
    There is no difference if I'm testing over switch 1 or Switch 2, i also tried Lan1 and Opt1 and different Switches.
    As long as i only use one Switch i get my 110mbit/s and 6ms Latency.
    I Know its not a big problem but it doesn't feel right, i hope you can help me and sorry for bad english.

    Pfsense APU 1c4d 2.2.1

    Greetings Neo


  • Rebel Alliance Global Moderator

    when you have 2 switches what is the uplink between the switches.. It is possible you have a bottleneck between the switches.  With an uplink between switches you not have a shared pipe that everyone on that switch has to share to get to the upstream switch.

    Its possible your switches have a duplex mismatch between them?

    Switches do not add 13 ms of latency.. you could have spanning tree issue?

    What switches do you have, how are you connecting them?  Fiber?  Lagg - just a single copper, is it 100 or gig?  How many clients are on each switch?  Are you doing any vlans?  Are these just layer 2 or layer 3 switches?



  • Hi John,

    Lan1->switch1(Netgear GS108E-100PES Layer 3 Switch)->switch2(Netgear GS108  Layer 2 Switch) ->~8Clients
                          |
                          -> Server and a Nas

    Lan2->Fritzbox7390->5 Clients

    Wan(VLAN)->Fiber "Modem"

    The Switches are connected with Gigabit single Copper.
    i can copy files to the Nas and Server from switch2 with 120mb/s

    i think i dont have stp running(failover right?)
    I also checked for a Loop but i couldnt find one.
    i also tested the Lan2 with a Fritzbox and behind the Fritzbox a different Switch(TP-Link TL-SG1008D Layer 2 Switch) same issue


  • Rebel Alliance Global Moderator

    gs108e is NOT a layer 3 switch - not by a freaking LONG shot!!!  Its a barely not dumb switch, lets call it a mentally challenged switch because smart would not be the word I would used and retarded is not really PC ;)

    120mb (megabits) is pretty slow.. I take it you mean 120MBytes?

    So your saying if you ping pfsense from your server you get what??  When you ping from client on your second switch you get what?

    So for example..

    So in simple layout I have pretty much same sort of setup

    modem - pfsense - switch1 (sg300) –---- switch2 (gs108t)

    So from pfsense if I ping something on switch 1
    [2.2.3-RELEASE][root@pfSense.local.lan]/root: ping 192.168.9.100
    PING 192.168.9.100 (192.168.9.100): 56 data bytes
    64 bytes from 192.168.9.100: icmp_seq=0 ttl=128 time=0.461 ms
    64 bytes from 192.168.9.100: icmp_seq=1 ttl=128 time=0.519 ms
    64 bytes from 192.168.9.100: icmp_seq=2 ttl=128 time=0.363 ms
    64 bytes from 192.168.9.100: icmp_seq=3 ttl=128 time=0.502 ms
    64 bytes from 192.168.9.100: icmp_seq=4 ttl=128 time=0.466 ms
    64 bytes from 192.168.9.100: icmp_seq=5 ttl=128 time=0.480 ms
    ^C
    –- 192.168.9.100 ping statistics ---
    6 packets transmitted, 6 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 0.363/0.465/0.519/0.050 ms
    [2.2.3-RELEASE][root@pfSense.local.lan]/root:

    If I ping something that goes through switch 1, through a trunk (allows multiple vlans) connection to something on switch 2 (my popcorn hour a110)
    [2.2.3-RELEASE][root@pfSense.local.lan]/root: ping 192.168.9.99
    PING 192.168.9.99 (192.168.9.99): 56 data bytes
    64 bytes from 192.168.9.99: icmp_seq=0 ttl=64 time=0.534 ms
    64 bytes from 192.168.9.99: icmp_seq=1 ttl=64 time=0.349 ms
    64 bytes from 192.168.9.99: icmp_seq=2 ttl=64 time=0.549 ms
    64 bytes from 192.168.9.99: icmp_seq=3 ttl=64 time=0.437 ms
    64 bytes from 192.168.9.99: icmp_seq=4 ttl=64 time=0.427 ms
    ^C
    –- 192.168.9.99 ping statistics ---
    5 packets transmitted, 5 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 0.349/0.459/0.549/0.074 ms
    [2.2.3-RELEASE][root@pfSense.local.lan]/root:

    notice any real difference?  So do that test from your pfsense..

    even if I ping from my machine 192.168.9.100 to something on a different vlan 192.168.2.98 that goes through switch1 to pfsense, routed and firewall to another interface on pfsense to switch1 on different vlan then through trunk to switch 2 your still only talking 1ms.. And my pfsense is virtual machine on esxi host.. So not really routing at wire speed if you know what I mean.

    So your saying you local lan adds 7ms something is not right..  lets do some test

    So if I ping from my 192.168.9.100 to my 192.168.2.98 - if you followed packet it would go through 3 switches, twice through switch1 and then to switch2.. routing and firewalling the traffic is what is adding the 1/2 ms or so.

    Pinging 192.168.2.98 with 32 bytes of data every 1000 ms:

    Reply[1] from 192.168.2.98: bytes=32 time=1.0 ms TTL=63
    Reply[2] from 192.168.2.98: bytes=32 time=0.7 ms TTL=63
    Reply[3] from 192.168.2.98: bytes=32 time=1.1 ms TTL=63
    Reply[4] from 192.168.2.98: bytes=32 time=0.7 ms TTL=63

    Ping statistics for 192.168.2.98:
            Packets: Sent = 4, Received = 4, Lost = 0 (0% loss)
    Approximate round trip times in milli-seconds:
            Minimum = 0.7 ms, Maximum = 1.1 ms, Average = 0.9 ms

    D:\Dropbox\tools>tracert -d 192.168.2.98

    Tracing route to 192.168.2.98 over a maximum of 30 hops

    1    <1 ms    <1 ms    <1 ms  192.168.9.253
      2    <1 ms    1 ms    <1 ms  192.168.2.98

    Trace complete.

    So lets see one of your clients on lan2 ping lan1 server on switch1 and client on switch2 what times do you get.. You are running different networks right, your not bridging anything on pfsense?
    And what does client on switch2 get for response when pings pfsense and when it pings your server or nas?

    edit:  Did you happen to set some sort of qos up on your 105e ??  It has some qos functions.. That could mess up stuff if not done correctly.



  • so John,
    yes i meant 120 Mbyte/s
    yes Lan1 and 2 are 2 Seperated Networks without Vlans Lagg etc.
    here is what i tested,

    Lan1 Client->Switch2->Switch1-> Nas or Server 1ms
    Lan1 Client->Switch2->Switch1->PFsense(Lan1) 1ms
    Lan1 Client->Switch2->Switch1->PFsense(Lan1)->Wan ~1-2ms
    Lan1 Client->Switch2->Switch1->PFsense(Lan2) 1ms
    Lan1 Client->Switch2->Switch1->PFsense(Lan1)->Client(Lan2) 1ms

    Lan1 Server->Switch1->Switch2->Client 1ms
    Lan1 Server->Switch1->PFsense(Lan1) 1ms
    Lan1 Server->Switch1->PFsense(Lan2) 1ms

    Lan1 Client->Switch2->Switch1->Pfsense->Lan2->Client 1ms
    Lan1 Server->Switch1->Pfsense->Lan2->Client 1ms

    Pfsense(Lan1)->Switch1->Server 1ms
    Pfsense(Lan1)->Switch1->Switch2->Server 1ms
    Pfsense(Lan1)->Fritzbox(is in Lan2)->Client(Lan2) 1ms
    Pfsense(Lan2)->Fritzbox(is in Lan2)->Client(Lan2) 1ms
    Pfsense(Lan1)->Fritzbox(is in Lan2) 1ms
    Pfsense(Lan2)->Fritzbox(is in Lan2) 1ms

    Lan2 Client->Fritzbox 1ms
    Lan2 Client->Fritzbox->PFsense(Lan1) 1ms
    Lan2 Client->Fritzbox->PFsense(Lan2)->Wan ~1-2ms
    Lan2 Client->Fritzbox->Pfsense(Lan2)->Switch1->Server 1ms
    Lan2 Client->Fritzbox->Pfsense(Lan2)->Switch1->Client 1ms

    So i also tested multiple constellations with tracert -d every hop was 1ms and i wasn't able to find unnecessary hops.

    On the Netgear "mentally challenged switch"  Qos is set to 802.1p/DSCP Based setting it to port based won't solved the problem it's not possible to "deactivate" it completely.(also tested it with another router without the gs108e in the network).



  • @johnpoz:

    gs108e is NOT a layer 3 switch - not by a freaking LONG shot!!!  Its a barely not dumb switch, lets call it a mentally challenged switch because smart would not be the word I would used and retarded is not really PC ;)

    Okay, I'm not going to lie. This seriously made me laugh out loud.