Upgrade from 2.1.5 to 2.2.3 - Login fails



  • Hi,

    after upgrading from 2.1.5 I can't login with my password. The password had a length of 30 characters with special characters inside.

    The problem is that the pfsense is in another coutry so I can't use the console to reset the password.

    Has anyone an idea what I can do?



  • I add some hardware details:

    Mainboard:  ASUS P9D-I
    CPU : Celeron G1820T
    Ram : 4GO RAM ECC



  • Nothing changed in that regard. There aren't any special character or length concerns there. I'm guessing you're either not trying the right password, or maybe getting redirected to a different system so not trying to log into the right box. One of those two has been the root cause of every similar support case we've gotten.



  • I see the right IP Address in the Browser and I tried at least 30 times the password. I also tried a Computer in the LAN of the pfsense and I have written the password in clear text before copy/paste it into the login screen. I'm 100% sure that I try the correct password on the correct machine:

    Any other ideas?



  • What does the login screen look like, the usual one? Not something that's popping up HTTP basic auth box or anything similar. That's enough tries that it would have locked out your IP, unless the attempts were spaced out.



  • I have attached a screenshot after the login attempt.

    It looks like the usual one. After I try my password it says "Username or Password incorrect". No Pop-up or anything else I had the case that after several tried the login screen doesn't respond anymore but this is only after several tries.

    ![pfsense login.PNG_thumb](/public/imported_attachments/1/pfsense login.PNG_thumb)
    ![pfsense login.PNG](/public/imported_attachments/1/pfsense login.PNG)



  • Definitely sounds sane. Have SSH enabled where you could try that?



  • I found an similar problem in this forum when updating from 2.1.x to 2.2: https://forum.pfsense.org/index.php?topic=88322.0

    If I understood it right the coding standard changed from 2.1.x to 2.2 from Latin-1 to UTF8.

    My password contain these characters: _£@;[{.#!

    Now the question is, if it is possible to calculate the "new" password with these informations?


  • Banned

    @mwagner:

    My password contain these characters: _£@;[{.#!
    [/quote]

    SCNR.