Timezone garbage on top of screen



  • Well it's not really garbage but it sucks to have it up there.  This is what i see at the top of the screen:

    Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /etc/inc/globals.inc on line 64 Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /etc/inc/globals.inc on line 64

    This is what I see in the Version box:

    2.2.3-RELEASE (amd64)
    built on Tue Jun 23 16:37:42 CDT 2015
    FreeBSD 10.1-RELEASE-p13
    Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /etc/inc/globals.inc on line 64 Warning: date(): It is not safe to rely on the system's timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /etc/inc/globals.inc on line 64 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/globals.inc:64) in /usr/local/www/guiconfig.inc on line 48 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/globals.inc:64) in /usr/local/www/guiconfig.inc on line 49 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/globals.inc:64) in /usr/local/www/guiconfig.inc on line 50 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/globals.inc:64) in /usr/local/www/guiconfig.inc on line 51 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/globals.inc:64) in /usr/local/www/guiconfig.inc on line 52 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/globals.inc:64) in /usr/local/www/guiconfig.inc on line 55 Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /etc/inc/globals.inc:64) in /etc/inc/auth.inc on line 1359

    Unable to check for updates.

    All I did was download the memstick version of 2.2.3 on 6/30/15 and simply assigned the interfaces and defined the IP address range.  Not using VLANs.  I have limited experience with pfSense and stay away from the big boy configurations like adding code or anything like that which is described in this thread.

    Checked the php.ini and timezone is correctly configured (first time using the edit file feature, only to see what was in the file, no modifications).  Also checked the file "globals.inc" and there is no date.timezone in that file.  Any other ideas?

    Also, if I ever try to enable PowerD, the router webgui stops responding and is unavailable.  It starts working after 10-20 seconds, asks me to login, and then gives me an 01 unread notice:

    [ pfSense is restoring the configuration /conf/backup/config-1435732361.xml]  I assume that the PowerD issue is separate from the above problem and so I don't mind leaving it unchecked.

    So any ideas on what is going wrong with the "garbage"?

    System:
    AMD 5350 Processor
    ASRock AM1H-ITX
    60GB SSD Drive
    Crucial 8GB DDR3-1600 RAM
    Intel Dual Lan PCI-e Card

    Edit 1: I'm assuming when it restores the configuration that it forgets my defined rules?



  • Same problem here, after upgrading from 2.2.2 to 2.2.3. I was able to get rid of the first message by finding the "date.timezone" line in  "/usr/local/etc/php.ini " and manually entering my time zone. (Interestingly, when I went back into the file, to copy the data here, the "MST7MDT" had been changed to "America/Denver".) However, I still get the second message in my Version box.



  • Update: the message in the Version box (on the dashboard) has gone away (even though we haven't changed anything), but now it's taking a very long time (maybe 30 seconds) to get past the login screen, after entering the password. I've checked DNS, to make sure it's working. What else might cause such a long delay?

    I also discovered, this morning, that we lost a couple of rules. We just needed to re-enter them, but I'm not sure why the update would have deleted them, in the first place.



  • @Dadoo:

    Update: the message in the Version box (on the dashboard) has gone away (even though we haven't changed anything), but now it's taking a very long time (maybe 30 seconds) to get past the login screen, after entering the password. I've checked DNS, to make sure it's working. What else might cause such a long delay?

    I also discovered, this morning, that we lost a couple of rules. We just needed to re-enter them, but I'm not sure why the update would have deleted them, in the first place.

    Did you get any notices at the top of your screen?  If you did, chances are it may have said something like "reverting to backup configuration" or something, which is why you lost your rules.  This, assuming you got that notice.